Laser light to weak when spindle speed matches, why?

I am running Lightburn with Neje Master 2 20w with GRBL 1.1f firmware. The laser light is not powerfull, it marks the wood, but is very weak. I havematched the spindle speed in the firmware with the device setting ‘S-value max’, both at 1000.

It does work if I put a much higher value in the ‘S-value max’ setting, and leave the GRBL setting at 1000. So for instance, s-value max at 32768. The laser is much more powerful then at 100%.

It is workable, but the power settting for a layer is not lineair anymore. For instance, anything above 10% means the laser is on full power.

Any idea what could be cause? Thanks.
Great software, lightburn, I am thinking of buying it.

If this is what’s happening, it means that GRBL is “throttling” the laser output, most likely because you are asking the controller to move faster than it is set to allow in the firmware settings.

Read the stuff under the “Speed / Power” graph on this post: