Laser Location with Xtool D1

Hi guys,
I’m sure this is another fairly dumb question but i cant seem to find an answer. I have an xtool d1, which doesnt have limit switches from my understanding so i cant really use the home function. Normally i have to manually move it home when i power on the machine. I have a grid burned into a spoil board, so my question is say i move the laser to x1,y1 manually. How do i tell lightburn that the laser is at those specific coordinates? Currently after i manually home it, i tell light burn to move it to those coordinates then manually move it to be exact. Its always i tiny bit off.

without limit switches you have to move the laser head before you turn on the machine and start LB, from that moment on LB assumes that position as 0,0

Are you starting the machine with the laser head mechanically butted against the back left corner? And you’re still getting a variance in position? If so, that’s a little surprising as I would think doing that would be more mechanically reliable than trying to align by sight.

If you want to force this there may be a way of doing this. I haven’t tested this. Also, it’s possible that your firmware may prevent you from doing this as xTool is known to prevent EEPROM writes.

Move the laser head to where you want 1,1 to be. Then run in console:

G92 X1 Y1

After issuing the command check that current position is listed as 1,1.

You may want to take a backup of your machine settings prior to doing this. I suggest you also run these commands in Console in advance and save them for reference:


Honestly the spoilboard was one of my first creations. Its very possible that i didnt have it all the way in its home position when i burned it, which may be causing the varience. Ive only been playing with it for about a week now so im very inexperienced. As far as commands go, do you have a link that goes into depth of how to do commands like that?

If it’s consistently off by the same amount every time then you’re probably better off reburning your spoil board. A mechanical indexing to the corner is likely going to be easily as consistent as what you’d get doing this by eye and much less of a pain.

As in how do you go about running the commands? Or how to learn what these mean?

If the former, then check LightBurn documentation:
Console Window - LightBurn Software Documentation

If the latter then a couple of good resources:
To understand GRBL $ settings:
grbl/ at master · gnea/grbl · GitHub
To understand general g-code reference LinuxCNC:
G Codes (

Thank you very much for the help!!

I think something may be off in the work area. When i burned the grid I started at x1, y1 at half inch intervals. The numbers on the grid are small so nothing falls into the area under x0.5. It printed the grid fine but when it printed the numbers I heard a click like the belt was slipping. It then continued to burn the numbers but they were closer to x1 than they are in the program. When i tried the home button it did the same thing. It moves across the y axis fine. When it does the x axis though it wants to go further than it can.

You likely lost steps at this point and all movements afterward can no longer be trusted.

I believe i figured it out. The laser pointer offset was set incorrectly. I played with it a bit and it seems to be opperating much more acurate. Though the working area seems to be a bit smaller than the defined amount in the program. Maybe it was from converting mm to inches

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.