Laser Mark Control Board V4 Connection Issue

I’m have a 100W JPT M7 Fiber Laser Engraver. It runs on a Laser Mark Control Board V4 “LMCV4”.

Computer: ASUS laptop brand new running Windows 11

Issue:
Lightburn won’t find the laser/ LMCV4 Driver/ USB Hub issue.

Things I’ve tried.
I had to add the BJJCZ Device via the Device Manager “add legacy hardware”. I updated the driver.
I contacted the manufacture, They had me disable my antivirus, Make adjustments to my Bitlocker security. Manually update the driver several different ways.

I have tried the Driver swap software that I’ve seen recommended in these forums but when I use it, Nothing is shown for my BJJZC, LMCV4 or USB Driver so there is nothing to swap.

I’ve installed Lightburn, downloaded and installed the USB driver but it never shows up in my device manager.

I’ve added my laser manually in lightburn, uploaded the proper markcfg7 settings file but lightburn still shows “Disconnected”.

I’ve changed my power setting for all of my USB serial bus controllers so they are all on all the time.

Thank you in advance for any and all ideas / assistance that is given.

Have you ever been able to connect to this device using EZCad? If not, I suspect a physical connection issue or a problem with your laser’s controller. One thing to try is opening the laser’s case so you can bypass the port on the back of the case and connect directly to the board. Sometimes the port or the run of cable between the port and the board can be faulty, and connecting directly will resolve the issue.

I have been using the last successfully since June 2023. My previous laptop connected without issue after i disabled my avtivirus software. Three weeks ago that computer died, so i bought a new one.
I’ve taken the case off of the laser. The lmcv2 control board light is green. I’ve connected directly to the board “bypassing the exterior port” still having the same issue. Ive also tried several different cables.

Is the cable running through a USB hub or USB-C adapter? Sometimes, adding in an externally powered USB-C hub/adapter can resolve connectivity issues.

Originally i had it running through a USB hub. I stopped using the hub after reading in many of the forums that thy can cause issues

It’s true that they can cause issues, especially if they are not externally powered. But in some cases, an externally powered hub can help.

I’ll have to try that tonight.

If you can’t see it from the device manager, Lightburn won’t be able to find it either.

This has to be a driver or a hardware issue with the cabling/connection.

You need to find the driver for your machine.

Good luck

:smile_cat:

I contacted the manufacturer after my knowledge ran short. They sent me the proper driver. I installed it, then I get an error from windows stating that it might not work properly. The solution for that was disabling my bitlocker security. Then I reinstalled and Windows gave me a new error. Stating that the driver was successfully installed on 0 machines. I tried to find a solution for this but I’ve come up short.

Why did you re-install windows?

Did you re-install the driver they gave you and disabled your security?


Looks like you found the problem… can’t help you with windows…

Good luck

:smile_cat:

I never reinstalled windows. I reinstalled the driver they sent. It was the same driver that came with the laser’s flashdrive. I had to disable bitlocker security so I could start up the computer in safe mode. This was due to windows not accepting the driver’s signature. The solution for windows not accepting a drivers signature means I had to disable bitlocker, start in safemode, in the advanced safe mode setting I had to disable driver signature requirements.
Once that was done I reinstalled the driver again. Got a new error from windows stating the driver was installed on 0 devices (Error 5) if i remember correctly.

If you re-installed the EZCad 2 driver, LightBurn will not be able to communicate with your laser. You’ll need to perform the Driver Swap to allow LightBurn to communicate.

I have tried this. One of the issues is that there is no USBLMCV2 driver shown in my device manager. I’ve tried zadig but when I open the tab there is no USB to choose.

That would indicate that your USB connection is faulty - we’d suggest alternative cables and connection paths, or attempting a connection with a different PC, to rule those out as issues.

I have tried a total of 3 separate computers and 3 different cables. All 3 cables and computers work fine for my CO2 laser and other USB devices. I’ve removed the outer case of the laser and connected directly to the LMCV4 Control board also.

After many hours of communication with the manufacturer It has been determined that the main board in my laser has failed. They are sending me a new one.
Thank you to everyone who contributed.

That’s great… I’m glad they are taking care of you…

Let us know how it works out…

Take some photos of the inside :pray:

Good luck

:smile_cat:

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.