Laser Master 2 is not detected

I just bought a Ortur LM2, and am having trouble connecting it to Lightburn. Figured I’d give this fourm a shout to see if anyone had a solution.

I am runing Linix Mint 20, and here is what I have tried so far:

  • Switching Cables
  • Switching Computers (Both running Mint 20)
  • Changing Ports
  • Manually creating Laser

The laser is recieving power, and after fidiling around with the power buttons I confirmed that the power and usb cables both worked and that the laser can move, but I cannot for the life of me connect it to lightburn to recieve code.

It also occured to me that perhaps Linux drivers are needed but my Googling has come up tragically short.

Any help is appreciated in advance!

I am replying to my own post because I figured it out and if some poor bastard stubles across this I don’t wanna leave them hanging.

Try this:

  • Open a terminal and run the following command:
    sudo adduser $USER dialout && sudo adduser $USER tty
  • IMPORTANT! Log out and log back in (this refreshes the permissions we just added)

Thanks for the follow up. And to provide further assistance, we have a section in our documentation that discusses this in detail here: https://lightburnsoftware.github.io/NewDocs/Installation.html#linux-installation

A post was merged into an existing topic: Ortur Laser Master 2 20W (2021 version) not recognizd or responding to Chromebook running Linux

I’m running Manjaro and this did the trick for me

1- go to /etc/udev/rules.d folder
2- create a Laser.rules file (sudo privileges required, “Laser” can be another word)
3- open file and paste:
SUBSYSTEM==“tty”, ATTRS{idVendor}==“0483”, ATTRS{idProduct}==“5740”, GROUP=“users”, MODE=“0666”
ACTION==“add”, KERNEL==“ttyACM[0-9]*”, ATTRS{idVendor}==“0483”, ATTRS{idProduct}==“5740”, MODE=“0666”
4- save file
5- restart rules, in terminal run: sudo udevadm trigger
6- DISABLE automount removable drives on your system settings
7- shutdown your pc
8- turn your ortur laser master 2 on and connect it to your pc
9- turn on pc
10- install lightburn, if you dont have it installed yet
11- run through the auto config, laser must be detected now

Fun fact: Kali Linux detects the laser “out of the box”, because it comes with automount disabled by default and other tweaks. You just need to install Lightburn and it works right away.

Hope this helps.

Quotations were wrong in the previous comment, it should be "value" and NOT “value”

SUBSYSTEM=="tty", ATTRS{idVendor}=="0483", ATTRS{idProduct}=="5740", GROUP="users", MODE="0666"
ACTION=="add", KERNEL=="ttyACM[0-9]*", ATTRS{idVendor}=="0483", ATTRS{idProduct}=="5740", MODE="0666"