Laser mode on grbl and/or power modulation

Hello, I just bought a Makerbase MKS DLC32 to upgrade my laser machine; after some troubles with the firmware installation (because of a problem with the display), I connected it via WIFI. Now my machine doesn’t control the laser power (only on and off). I got this message from the console: " Your Grbl may not support Variable Power mode (M4)

If your laser does not turn off between cuts,

switch to the GRBL-M3 device"
Thank you so much.

Are you using the most recent firmware for the board?

If so, make sure $32=1 in GRBL config.

Yes, I downloaded the latest firmware version from github and checked my grbl config, $32 is equal to 1.

Odd. What are values for $30, $31?

What is S Value Max in Device Settings?

$30=1000 (but I already tested it with 255) and $31=0

Can you confirm specifically what firmware you’re using?

Also, is your concern based only on the message or have you confirmed that power modulation is not functioning?

This is the information: " [VER:1.1.2021122201:]


[MSG:Using machine:MKS DLC32]"
Yes, I confirmed that the modulation is not working, I tried to do a gray scale, but it didnt work.

Can you described what happened with it? Essentially if you can control power at all, that’s power modulation. Meaning if you can increase/decrease power levels.

As for M4 Variable Power, if it works at all without cutting traversal moves that’s likely working.

I see firmware revisions from 2022 for all variants of the firmware. Which specific file did you get?

Are you looking here for your firmware:
MKS-DLC32/firmware at main · makerbase-mks/MKS-DLC32 · GitHub

No no, I can’t control power at all (only turn it on with the maximum power and off). And yes, that is where I got the firmware from.

In this case it’s likely nothing to do with M4. Likely something more fundamental.

  1. What specific firmware file did you use?
  2. How have you wired the laser module to the board? Can you upload photos of the wiring at board and laser module? Hopefully with PCB markings showings.
  3. I think I recall some others using Two Trees Laser Modules struggling with power modulation but I could be mistaking it for another similar sounding brand.

Going back to simple basics.
Draw 1 line and do an array to get 10 lines. They can be short. inch or so.
Put each line on a different layer and keep the speed the same.
Change the power for each one going up by 10%. (10 to 100%)
Run that and see what the outcome is.
Use line not fill.

It worked, the machine regulated the power by doing that, but when I tried with a material test or with a file the machine got restarted. It looks as if the machine was kidding me.

Load up one of the bad files and upload a screen shot of your cuts / layers window.
And the cut settings editor window.
Grey scale is not a lot of fun to get right.

I’m using GRBL 1.1.
The hardware I’m using is a Makerbase MKS DLC32 V2.1
The laser wiring is the same that the old controller I was using, I checked the position of the pins and it’s the same for both of them.

The test that I’m trying to use is the generated one by Lightburn (I can upload the g-code by the way) and the other file that I’ve tried was a random picture from my computer.

Maybe faster. Use a small pic and set it to jarvis dithering.
Leave constant power off.
I have no problem with lightburn generated images.
See if that does anything.

You don’t need a small pic, just shrink it down to a 2 inch or so burn.

I can’t see the constant power option

That help?