Laser module added to DIY table

I have a Neje A40640 laser module that I mounted to my DIY CNC table that uses a UCCNC UC400ETH controller and 5 axis BOB. I have tried to save the G-code from Lightburn to load on the controller PC and it works somewhat. It seems the power is not reflected to what I enter in Lightburn. I first started with a Arduino Uno and GRBL and all worked fine. I have tried to change the device to a CAMBAM but the G-code does not have the power setting (S 0 to 255), so that will not work. Is there another device I can switch to to generate a usable G-code. I think the UCCNC will also need to have M106 to fire the laser and M107 for turn off. Any Help will be great.
Thanks Tom

I came up with this process while working with another UCCNC user. See if it works for you.

Based on the last test I think I have a procedure to make this work.

  1. Setup a device type as Marlin in LightBurn.
  2. In Device Settings make sure S Value Max is set to 255
  3. In Device Settings make sure to select M03/M05 for Laser Control Command
  4. Create your design, then push “Save GCode” in Laser window and select a filename
  5. Open the saved G-code in a text editor and make the following changes:
Replace all 'M05' with 'M11'
Replace all 'M03 S' with 'M10Q'
Add a line with just 'M3' before the first line with 'M11'
  1. Run g-code in your control software

More on the background of this in this thread:

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.