Laser moves in opposite direction and runs into the rails

So I’ve been having a problem lately with my laser’s movement.
When I first started out I had no issues, but now I can’t figure out why my laser runs into the rail.
As if the controls were inverted.
My setup is a 7w J Tech laser on a Shapeoko 3 XL. (Origin is rear right)
I’ve read that this CNC works in a negative grid area, but I’ve no clue what changes I need to make.
Now, specifically, when using Lightburn’s controls, when I click left, it moves right and into the rails. But when I click right, it moves to the right, again hitting the rail. Same with forward and backward movements. Both buttons, move to the rear hitting the rear rail.
I’ll attach images of my current settings.

Also, any advice or recommendations for any changes to my settings would be appreciated.

How long has it been working correctly before this issue came up?

Can you explain in detail what you mean by this? There are many different concepts of origin and I want to understand how you’re using this word.

When you first started using the machine in LightBurn did you make any configuration changes in order for this to work?

Can you take a photo of the machine oriented in a way where the “front” of the machine is facing you?

Some core questions:

  1. Does your machine have homing switches and automatically home when powered on? If so, to what corner does the machine home?
  2. Is the laser homing properly now?
  3. Do you also use this machine for CNC? If so, have you recently used it for that purpose? What program do you use for that and do you make GRBL changes to accommodate that?
  4. Can you run these commands in Console ideally following a homing operation but not necessary if you’re having issues. Return output please (as text).

I started around December 2021.

So by origin, I mean the starting location of my laser. Basically where it homes to on startup. Refer to the photo attached. The laser’s current location is “Rear Right”.

I did make a few changes to “$$” when I started. I don’t recall exactly, but I believe I either looked here or emailed Lightburn directly. I was told to make these changes; $10=0, $13=0, $30=225, and $32=1. all the others were left as is. This somehow fixed both direction problems and “laser fire” problems I was having at the time. This worked for me from December 2021 till mid-October of this year. Now I’m only having issues with direction.

The same photo above can be used for the machine’s orientation. Where the laser currently shows to be, is what I refer to as Rear Right. From my point of view, the closest side to me would be the Front

I’m not sure what homing switches would be exactly, but it does auto-home on startup and I can also manually turn that off so that it doesn’t auto-home.

My laser does auto-home properly and always goes to the same position with no issues. But even after homing, the direction is still incorrect.

Yes, we do use this machine for both CNC and laser engraving. And we use CNC engraving much more than laser, but never really had a problem switching back and forth when needed.
The only programs we use for this machine are Lightburn for laser engraving and Carbide Create/Motion for CNC engraving.
For the term GRBL, I’ve never noticed it appear on Carbide, only on Lightburn, so I’m not sure how to answer that part of your question.

Here’s an image of what I got after inputting those commands;

Your setup is kind of interesting.

Thanks for the thorough response.

A few additional questions:

  1. Are you experiencing any issues in Carbide in terms of jogging controls?
  2. Previously when you moved the laser to the front-left, did position values increase (more positive) or decrease (more negative)?

It’s rare when carbide has the same issues. But when it has occurred, I simply hit “Send Configuration” and that t would reinitialize the machine and the problem is gone.

It would go further into the negative value if I’m not mistaken.

Hmm… I’d like to get you back to your original settings but not sure how that was setup.

In the meantime, let’s see if we can get it working based on how it’s currently setup.

Can you run these commands in Console. And then test if your jogging controls work correctly?

G10 L2 P1 X-845 Y-850

That should put the lower left at 0,0 with positive coordinates going up and to the right from the bottom-left.

Can you then power cycle and then retest?
Check the following:

  1. Check that jogging controls work as expected
  2. Check that bottom left is indeed 0,0 or close to. Top-right should be 845,850 or thereabouts
  3. Other basic function of the laser

That worked! Everything moves as should. I ran a test run last night and it came out perfect. Though by this morning I noticed a minor change. Now the edges burn slightly darker than they should.
I didn’t change anything other than the command you sent. I played with different speeds and powers as well as over-scanning percentages, but it’s still over-burning the edges.

Oh never mind. I figured it out. $32 was at 0 rather than 1. I Changed it to $32=1, and that fixed it.

You will have better control over your laser if the value for $30 is the same value as S-value max.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.