Laser not burning

laser does travel but it does not burn at all.
manual laser power from switch does it on

The fire does not work either

this is using grbl 1.1g on xcarve 1000mm

What is $30 set to in your firmware settings? (Type $$ in the console and press enter)

This is the value that controls the range of PWM output for the spindle and laser. I have seen XCarve set this to 1, meaning you get “on” and “off” and nothing in between. This is discussed here, along with the other most commonly problematic settings:

HI I followed the instructions but still no luck. I’m lost on what to do next please help!!

Start by typing $$ in the console and pressing enter. The controller will respond with a bunch of text - copy and paste that here.

1 Like


That’s a good start - it does look like your settings are correct. Next, go to Edit > Device Settings in LightBurn, and tell me what the S-Value Max setting is:

If it isn’t set to 1000 (matching the $30 setting in your firmware) change it to that.


At this point it’s possible that you have a wiring issue or a bad laser. Your settings look right. When you enable the Fire button and turn up the percentage, the laser does not turn on, correct? If that’s the case, I would double check all the connections, and if that’s still not working, contact the maker of the laser to see if they can help you - I can’t see anything settings related.

Got it to work it seemed to be bad connection on one of the cables

Hurray!!! Thanks for you prompt help


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.