Laser not connecting to laser

I have two lasers mira 9 and mira 7. I just set up the 7 with the piburn and had issues getting it up and running. It was telling me no laser connected. When I connected the cable directly to the ethernet inside the machine (not the connection outside) it worked. But today when I turned on the machine it’s telling me that it isn’t connected to a laser so I did the following trouble shooting

  1. Checked that I’m connected to wifi - yes
  2. upgraded the latest software of lightburn
  3. unplugged/replugged the bridge
  4. Took ethernet cable out and back in
  5. Hit esc on the laser keypad
  6. Hit reset on the laser keypad
  7. Restarted the mira 7

Nothing has helped and I’m drained from trying to figure this out. The only difference I have done that I don’t see why it would bother the 7 is that I ran a job to mira 9 via it’s bridge yesterday. 7 wasn’t even on. I’m not sure what’s going on and I really hope this is a easy fix and a user error and not a deep dive into an issue. I have a pc – windows 10.

-lightburn screen shows disconnected
-When I go to devices – it shows my mira 9, mira 9 bridge, mira 7, *7bridge (the * was not there before)

  • scanning lightburn bridge devices - no laser connected but shows ip address of bridge. then shows 9bridge and address
    -When I choose to edit the *7bridge from device list it shows - ip address that doesnt match the one of the scan
  • IP Address on laser keypad
  • bridge has two lights in back on and one in front on
  • directly plugged ethernet into the machine inside not outside port

could the ethernet cable connecting to machine and bridge be bad? it’s the one that came with the bridge

Possibly but unlikely if it’s been working. Can you confirm that you can see two lights flashing on the ethernet port of the Bridge?

The asterisk indicates default device so shouldn’t be an issue.

Can you elaborate on this? Screenshots would be useful.

Are you able to connect a monitor or TV to the Bridge? Would be useful to see the status message there.

device scan
so now the ip matches before the scan one ended with 26

what do you mean connect to monitor to read? this?
bridge www

So it looks like connectivity to the Bridge is not an issue.

If you click the Network Log link what does it show there?

Did you check the lights on the ethernet port to confirm you’re getting flashing on both lights?

You’ll need to simplify these for me. I know just enough to get by but once it’s an tech issue i’m clueless. how do i check network log link and the port on the bridge or inside machine

In the screenshot that you sent there’s a link that reads “Network Log”. What happens when you push that?

Physically examine the Bridge. Where the ethernet cable plugs into the Bridge there should be 2 small LED lights located on either side of the port itself. Are those two LEDs flashing?

solid green on left solid yellow on right

did you see the network log link above?

This indicates that the network is at least on. They should blink on active communication.

That’s a local link only relevant for your system so I won’t be able to connect to see the contents. Do you get anything back when you click it?

What happens when you right click on the “Devices” button in LightBurn to force a reconnect?

a long list appears on the network log… do you want me to screen shot the most recent items?
when i right click the devices. an hour glass appears and then disappears

Can you copy/paste the most recent 40-50 lines or so?

Does the laser ever show as ready?

it did days ago when it was working. but not today. my mira 9 works

Okay. That’s not showing what I would hope it would show. I was hoping to see a positive connection to the Ruida from the Bridge.

So right now you have what looks like LightBurn->Bridge connectivity but not Bridge->Ruida.

Does your Mira 9 also have for the controller IP? If so, can you try plugging the ethernet cable from the Bridge connected to the 9 into the 7? Do not change anything else.

Then in LightBurn connect to the 9 Bridge which should now be controlling the 7 laser. Are you able to control the 7?

This will isolate if the problem is with the Bridge or the Ruida.

I have 7 apart at the moment fixing an air hose. once i get this taken care of I will try this.

I unplugged the 9 bridge and used the ethernet cable that came with the 7 and plugged it into the 9 bridge. I then connected to 9 bridge in lightburn, sent a file and it went straight to the laser and showed up in the keypad correctly

Okay. So the issue is strictly with the Bridge or Bridge setup.

Now try this.

Take the SD card that’s currently in the 9 Bridge, then put that into the 7 Bridge.

From LightBurn, connect to 9 Bridge and retest.

This will isolate if the issue is with the Bridge hardware or with the configuration.

i took sd card out of 9 bridge put it into the 7 bridge. connected 7 bridge back to 7 laser machine.
went to lightburn connected to bridge 9 and tried to send file
file transfer failed
is this what you wanted me to try?

I would think her post where it made it to the other laser would indicate that the bridge was good and point at the controller?

I would check that the window on the Ruida is showing that the lan is on. You can also see it inside on the led panel


Good luck


Yes. To me this implies a hardware failure on the Bridge itself. If I had to guess it would be a failure on the ethernet port since it seems like wireless is working.

I’ll ask @Colin or others from LightBurn team (@JohnJohn, @JTR) to confirm diagnosis or provide other diagnostic steps.