Laser not cutting in the corners

Hi there, sorry newbie question here, just trying to get top to speed on my new “toy” I have added a 15w diode laser to my 3018 pro cnc. And I can create designs and cut them or engrave etc. But I’m having a few what I can what I’m hoping is tuning issues. If I do multiply passes I can cut thru thin MDF or plywood etc, but it’s taking a lot more passes that it needs to because the power is dropping off in the corners. If I do a simple square as a test it looks fine on the top, but on the underside I can see it’s not fully cut in the corners. I can keep doing more passes and it eventually cuts all the way to the corners, but I’m assuming from what I have read on here that it has something to do with the M4 and Lightburn automatically lowering the power as the laser slows down for the turn etc. But I can’t work out how to adjust this setting for just a line, I can see a max and minimum power settings but minimum is greyed out for “line”

So can someone please point me own the right direction to adjust this


In laser 1 power options (min/max), try to set higher values for min. power!

The minimum setting is greyed out for “line”, I can only enter a maximum value

GRBL lasers only have two settings: constant power (M3) and variable power (M4), and you don’t get to choose the low value used by variable power.

You can switch to GRBL-M3 to have it use constant power, or increase your acceleration some which will increase the speed through the corners and not drop power so much.

We’re adding support for constant power mode to the ‘GRBL’ profile so you’ll be able to choose, per cut, whether to use M3 or M4 mode, but it’s not ready yet.

Thanks OZ, I adjusted my acceleration settings, and it cuts all the way to the corners now. So many new things to learn

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.