Laser not firing on Sculpfun

Ive been using my Sculpfun Laser for months. This morning I turned it on. Everything seemed fine. I set up what I wanted to engrave, everything worked just fine. Gantry, movements…everything except no laser !!! Im definately not real tech savyy but dont know what else to do…

Can you take a screenshot of what you are doing. Also show the power level and speed settings.

In most cases, this is caused by a loose / broken cable. Check the wiring carefully if it still works. Here are some guides on how to check: Guide to mechanical adjustments and maintenance

OK Im trying to send you screen shot etc. I have a Sculpfun S9 and I usually engrave at 100% at 2700 rpm.

OK Im trying to send you screen shot etc. I have a Sculpfun S9 and I usually engrave at 100% at 2700 rpm.

Wow, not sure what material you are engraving, but to do it at 100% seems a little extreme.
I engrave a lot of oak at 1000 @ 55% (crosshatch). It is just deep enough to veneer.

If you are just engraving, you are always better off to use a lower power, that will also make you have to decrease the speed. I don’t run my laser at 100% even when cutting. I would usually use 95% power and speed of 300 mm/min using 6 passes to cut through a 1/4" piece of oak.

I hope you didn’t burn out your laser already.

Does the laser come on when you are framing? If it does, your laser most likely is fine.

I would definitely lower the settings from now on. Try to find a lower speed and power that would do the same job. Actually, running at a lower speed and power will make the letters look even better.

First thing you should do is make sure your lens is clean. Running at 100% is probably throwing a lot of burnt material and soot onto the lens.

Oh I didnt know all these things lol…When it powers uo and I frame the “on” light on the laser module is on (on left as facing it) however the laser itself never fires and the light on the right does not come on either…

Sorry Dave, not sure about that. Maybe your laser is fried. Don’t know for sure.

OK So bought a brand new laser diode set it up…STILL NOT FIRING!!! wire loom? Software? Pretty soon I should have just gotten new unit!

Did you check the cable? If it was not fixed properly, it’s most likely broken. Very common issue.