Laser not printing where guide head marks show (red cross hairs) & LB grid not display correctly

This is actually two questions although possibly related:

1.) I noticed (at least recently) that the red laser cross hairs on my Atezr L2 36watt mchine are not showing where the laser is actually cutting. I had been under the impression that they show what will be cut, so when you run a “Frame” command button, it will frame the cutting area with those red crosshairs. how ever, it seems to NOT be framing the cutting area, it’s framing to the RIGHT of the cutting area, making lining up my position a nightmare.

2.) I also noticed (again, just recently) that the grid display in light burn SHOULD BE 410mmx410mm as I have my machine set-up to in the program (I did double check), but it actually is only displaying “410mm (x axis) and 240mm (y axis)” and I CANNOT understand why or how.

I am wondering if problem #2 is causing problem number 1? Although the issue seems to be the X axis not running to the correct place.

I am new to this, although did produce a few items already that didn’t give me grief.

The process I had been tryign to do, was engrave color into steel. I had been used a powdercoated steel sheet about 1mm thick, and it wasn’t burning through it, so I decided to do a clean burn of the coating off FIRST and then run my color sequence blocks over it (on the now bare metal). I successfully cleaned off the coating, but when I dragged my color sequence into the place the burn box had been on the grid, it REFUSED to print it there. (box outline had been deleted from the screen too)

So trying to line everything up, I’m relying on the red lazer cross hairs, but HOW to I get them to show where it will ACTUALLY be cutting?


Maybe,… It should not affect the laser head directly but…
Did you check your “working size” is set?

Have you correctly set the offset for the crosshairs, plenty of YouTube on how to do it.

Yes, I figured that might be the cause, but both display 410.00

you can see the grid in the background here too!

I have not, I didn’t see any mention of it in my set-up manual. I will have to take a look, thankyou!

Normally in LightBurn this is handled by the Pointer Offset in Edit->Device Settings. However, it looks like the Atezr machines have an inbuilt mechanism to handle this called “Auxiliary Positioning”. Perhaps look this up in your manual.

It looks like to me you’re just not showing the full workspace. Go to Window->Zoom to page to show the whole area.

Okayyyyy, I’m a dork.

In regards to the auxillary positioning: YES – I set-up a button for that at the beginning of loading in the software! Also an autofocus button which I use frequently, lol but didn’t know what the auillary positioning button was for (THANKYOU!)

In regards to the grid, I closed the program and re-opening it and POOF, back to 410x410!

Thank you sooooo much!

BUUT, now theres a NEW issue. Now it keeps trying to go “past” home. It always went home nicely and I do have a sensor on the Y axis but not the X axis and it keeps trying to run left BEYOND what it should. And it’s also NOT registering the position of the laser either :frowning:

When I tell it go go home, it goes but then vibrates badly trying to force it beyond. It will phase out with an Alarm code 9 if I let it go on, but I just turn it off. It does not matter WHERE the laser is, the same thing is happening.

**I had found the area to calibrte the cross hairs and run through those steps, but everything somehow got out of whack :frowning:

Is it working correctly homing the Y axis by not the X axis? Or vice versa?

You likely do have a switch or sensor for X as well that may not be apparent. Have a good look for one. Then try to sort out why that switch/sensor is not able to be engaged.

Also, is it possible that engaging the auxiliary positioning is shifting the laser in some way that would cause this? Can you disengage the shift in that case? I don’t think this is likely but this would depend on how the shift is being handled.

It didn’t do this until I adjusted the cross hair (apparently there was a step on the laser itself where you dial it in better and I missed that.) Then I went through the next steps to do the auxilary positioning and now it won’t even run to the correct spot on the grid to frame my item, it just frames it at zero.

Also, under the “Move” tab, I had THOUGHT that when I clicked “get position” it would grab to position of my selected item on the grid, or at the VERY least where the laser was SITTING. At the moment it doesn’t do either . Just reads 0,0.

On a side note, PERHAPS maybe my laser ISN"T running to the full X length, see photos.

This is as far as it can go, and where it stops for home. I cannot move it further even by hand. Cross hairs show where it reads 0,0 . I’m not sure what to make of this, I figured that’s just how it is, and you mentally adjust accordingly, but maybe I’m wrong and it really SHOULD move all the way to the left and THAT’S why the laser is mad beause now it finally realizes this too?

Or something else? Should I just delete off my laser and re-install it? UGH. so dumb I spent all day on this and just needed to get ONE THING DONE :frowning:

I can try to directly add in coordinates and put the X to zero and the y to maybe 200 and see what happens, if it tries to grand again… It WILL move to coordinates if I input them directly…

It successfully traveled up the x axis at what it considers “0”. I set it to X=0 y=200 and it traveled directly upward with no issues. So it SEEMS to be some sort of home issue?

Can you detail out the steps in adjusting the cross hair and the auxiliary positioning process? Or copy from the manual where this is explained?

When crashing on homing, which axis is it crashing on? Or is it no longer crashing? Can’t discern from your description.

If it’s not crashing on homing but rather crashing on framing or other operation there could be some sense to that based on auxiliary positioning.

Likely no value in doing this and unlikely to fix the issue as it’s likely something on the laser side.

It only “crashes” when I send it home, it will travel the full length of the Y axis just fine, but the X axis it travels to the left and keeps trying to RUN past it (horrible angry buzzing sound).

If the laser is trying to run a pattern and I tell it to stop, it also seems to “get confused” and if I tell it to “frame” the area again it instead travels up and to the right , makes another angry sound and then stops. This part it has done since day 1 though. It doesn’t like to be interrupted during a burn.

Also, I had this area framed in with the cross hairs, but it still seemed like it was running mostly to the left of the crosshairs.

I actually just ran the auxilary positnoiong and THAT seems to be working ok as far as I can see.

Now just issues with the home . . .

So does auxiliary positioning only work using “User origin”?

I don’t see how this would affect homing, however.

3 questions:

  1. you described a crosshair adjustment process. What does that entail?
  2. did you check to see if there was indeed an X homing sensor? And why it might not be getting triggered?
  3. can you move the laser head all the way to the lower left where it should be triggering the sensors and then run these commands in Console? Please return all output:
1 Like

I may have unintentionally discovered the issue (perhaps). I ended up losing ALL X axis movement and it would travel to home on the Y axis, but refused to move on the X. I attempted to push it to home gentlely after turning it off, but it WOULD NOT BUDGE.

So I took the X axis cover off, and low and behold BOTH screws holding the laser head bracket into the x axis had FULLY come out. I’m not sure if they had never been tightened at the factor or had loosened from vibration during usage.

Anyway, I will add a tiny drop of lock tight and re-install them. Hopefully this was the issue. Likely I will have to re-calibrate my machine though, correct?

Here is what it listed:







Target buffer size found















It SO FAR has been going home OK since I put the screws back in. However, something else seems to be “messed up” o the X axis. It seems to “jump” to the right when it runs auxillary positinioning. I’m following the directions exactly as the manual asks, but also add “focus” in before I click start. When I click the auxillary positioning, it jumps the lazer to the right a few inches, enough to where it won’t print my project without overrunning the axis and grinding.

I did a test of the calibration, and something is way off. I input Y=“410”, X=“0” and clicked “Go”. Instead, the laser head traveled to 410, 410! When I changed it directly to 410, 410 in the corrdinates list and clicks go, it tried running further right and threw error code “ALARM:1
Hard limit triggered. Machine position is likely lost due to sudden and immediate halt. Re-homing is highly recommended.
On or near line 4:”

So I changed the input to “X=50, Y=410” and clicked GO and it again tried running to the right and threw the same code.

I clicked “return home” and it went home just fine with no issues.

So, it seems to somehow have reversed the issue. First it tried traveling too far to the left, NOW it’s trying to travel too far to the right.

I also double checked the calibration of the auxillary positioning (done directly on the laser’s interface) and it was spot on…

I also have the “move from machine zero” option OFF, located in the “MOVE” tab next to console in the program.

Okay. I don’t see anything disturbing from the output.

I think it’s supposed to shift the laser module such that your primary laser is positioned where the crosshairs used to be. Is that what’s happening or is this something more than that?

It’s not clear to me how the controller manages the auxiliary positioning and if it’s still protecting from crashes with soft limits. How much would you say the laser module is shifting? Can you simply avoid putting designs on the right side of the bed?

If this becomes too much of a fuss you may want to consider using LightBurn’s builtin pointer offset. It may be less fuss.

How do you know it’s going to this position?

Yeah. I’ve never really understood how that functions so leaving it off is the right move.

Please do the following:

  1. Check all jogging controls, do they work as intended and do they move the correct distance as specified?
  2. Run the following commands one line at a time in Console and return the full output please.

[MSG:‘$H’|‘$X’ to unlock]





Grbl 1.1h [‘$’ for help]

[MSG:‘$H’|‘$X’ to unlock]







































































I THINK it’s doing better, although SOMETIMES when i hit auxillary positioning it shoots far to the right instead of a small bit to the right . . .

Okay. It seems to me that the auxiliary positioning may be handled at a lower level than what’s exposed at the work positioning level. Meaning that the controller isn’t aware or rather doesn’t take into account the auxiliary position when reporting current position. If so, that’s an interesting approach and you’ll just need to be cautious not to have the machine in auxiliary position when it could potentially crash the machine or possibly vice versa.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.