Laser not shutting off between letters

When running in Lightburn all appears ok . when i run it on my Longmill CNC all letters and in between the letters is black, in other words laser operating all the time, even burns a line from word to word

yep… $32. traverse lines showing.
super common problem switching from machinery to photons.

Open the Console and type $$

Copy and paste that in the response.
I can show you countless other examples here that are similar.

I went into the console ., (GSender) entered $$ high-lited all and would not let me copy is it something i am doing wrong can’t seem to copy and paste,

From the LightBurn ‘Console’ window, you should be able to copy and paste the results here.

This is worth review, Common Grbl Setups - LightBurn Software Documentation

You might need to enable “Laser Mode” if you have GRBL 1.1f or later ($32=1)

Waiting for connection…

Grbl 1.1f [’$’ for help]

ok

[VER:1.1f.20170801:]

[OPT:V,15,128]

Target buffer size found

ok

$$

$0=10

$1=100

$2=1

$3=5

$4=1

$5=0

$6=0

$10=1

$11=0.010

$12=0.002

$13=0

$20=0

$21=0

$22=0

$23=3

$24=25.000

$25=1500.000

$26=250

$27=1.000

$30=1

$31=100

$32=1

$100=200.000

$101=200.000

$102=200.000

$110=4000.000

$111=4000.000

$112=3000.000

$120=750.000

$121=750.000

$122=500.000

$130=762.000

$131=812.000

$132=105.000

ok

Your $30 and $31 values are strange - Those should be the Maximum and Minimum spindle rate values that will be sent by the sending application. Yours are the wrong way around.

Most common for laser use are $30=1000 and $31=0, and then you set the ‘S-value max’ setting in LightBurn’s Edit > Device Settings window to match the 1000 value set in $30.

I have used the laser prior and had no issues( still in the learning curve) I installed an update for my gsender and appears I had issues since my update. Hard to say as update was put in a few days ago and just starting to use the laser on the last est update today

Thank you, had to leave my machine , I will review in the morning again thank you for your time and effort

I just received an email from Sienci (suppliers of LongMill CNC and laser) they are indicating there was an issue in the latest SW update and are working on correcting it, so for now I have to manually enter correct numbers in $30=100 and $31=0. I will advise, thanks again for everyone’s help

Thank you I have the unit up and running, question who or what determines the svalue in light burn. I checked and the svalue was 100 in lightburn, but just about everywhere I look on line it is 1000. How do I know what the setting should be ( it is working with 100 currently) only because I set $30 to 100 to equal the svalue in lightburn- just want to make sure setting is correct

As long as the numbers are the same it should be fine.
I have not experimented with a number under 255 for the S-value so i’d suggest setting both to 1000 and calling it a day.

the controller uses 0-255 to control the spindle internally and i’m still looking at how that number is generated and acted on by the motion controller.

I don’t know if you lose more than half the quality or resolution or control if 100 were selected for both numbers.

Thank you, I was told by Sienci to set it at what the svalue was in lightburn. It was 100 so I set my $30 at 100. Do u know if Lightburn determines what the Svalue should based on laser equipment installed

You can read GRBL controller settings into LightBurn and I believed that it would populate the settings.

So… I checked…

I changed the $30 value in Console to 89 because it didn’t exist anywhere else. Then i went over to ‘Machine Settings’ and it was there.

It was not in Device settings - There S (spindle speed) remained at 1000.

I would opt for a number that represents the granularity that the GRBL controlled device offers. A laser could easily handle 1-1000 milliseconds of pulse with at 1khz.

the S=100 strikes me as being a very unusual choice. 1000 would not be unreasonable - what were the factory numbers on your GRBL device?

Thanks Jon, I will change to 1000 and do a test will advise

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.