Laser not shutting off while moving between things

I see this is a pretty common issue; but none of the advice here has helped.

Currently running an OPT PLH3D-15W laser on an inventables X-Carve. Have done all the steps provided in both the Lightburn and the OPT instructions. Have sent the $32=1 in both Easel and Lightburn via the console. Changed the S value and many other variables. Running GRBL 1.1f, current $$ output is





































Any help would be very much appreciated.

This tells grbl that it’s controlling a laser, not a spindle. On a spindle you rarely stop it, just lift it up and move it over to the next spot… a laser must turn off during these moves. That’s the purpose of the $32 value …

You appear to be setup properly… at least with $30 through $32.

Check that the S-Value max is set equal to $30. This is in the device settings.

If your settings are OK, then you need to chase it down from the laser module and work backwards.

You can use a voltmeter to check the PWM output of the controller… 50% power should read 50% of 5V assuming a ttl compatible 5V pwm signal.


Ty; I’ve tried $32 both with 0/1

for $30 The default S-Value light burn picked for my laser was 12000; so I’ve tried changing $30 to match that; as well as setting both $30 and the S-Value to 1000; with no luck still.

When debugging things, you have to ensure it’s configured properly… Changing already determined working values is not really a good technical approach.

You didn’t mention, but the assumption is that this is a new build and has never worked correctly?

Did you measure the laser control signal for the proper voltage? It should be a pwm signal, not analog.


Yes, just got the laser. Have been cutting awhile using Easel on my xcarve but the laser is new.

As far as testing the voltage; havent done that yet; would that just be checking the hot power leaving the pwm into the X-carve controller?

An ssl (diode) usually has three inputs, ground, supply voltage and pwm or the laser on/off signal.

You want to measure from the PWM to ground. Change your percent power should result in a change to the pwm read voltage. If you have a scope, that’s better, but a voltmeter works with pwm control.

Ensure your board isn’t using an analog control signal for a spindle.

This controls how long the laser is on over a period of time.


Figured it out; theres was 0v going into the X-Carve controller from the pwm thingy. The cable that was shipped had a break in the PWM (Brown). I cut the cord and re soldered an end onto it now it works fine. Thanks for the help.

1 Like

Glad it’s up and running…

At 0 volts, the laser should have been off, yet it was stuck on… Most laser modules will not lase with just power applied, then need to be told to turn on.

The controller is sent gcode that tells it what to do. It’s up to the controller to generate the pwm to control the laser… so the signal originates with the controller → laser module.

Have fun :tada: