Laser not turning off on crossing whitespaces in CUT mode and Inverted burn in Graphics mode


A few days ago i started using Lightburn V0.9.09
Ive look a while on this forum but couldnt find something related to my problems.
So therefore ive added this post.

I am using a setup thats a 3D printer with a Marlin operated firmware on it.
On Lightburn i use the generated GCode.

2 strange things i have and i cannot find whats wrong.

When i want to cut something and i use the LINE mode in Lightburn, the laser doesnt turn off while crosssing whitespaces. It already starts burning right at the start of the process, just when it want to move to the start location where it actually has to burn.
The GCode looks good and it sure has the M106 S0 line of code in it to turn the laser of at that point. But it doesnt.
When i execute the M106 S255 and M106 S0 codes locally on the printer itself, the laser does go on and off as expected.

Second thing is when i want to burn a grafical image. It burns it inverted. That is, everything thats white on the image gets burnt and everything thats black on the image turns the laser off. In Lightburn the image looks normal and is not inverted in any way and when i select the inverted image option in Lightburn the image burns normally, so white is laser off and black is laser on so to say.
But it does the same if i create some text, everything is inverted on the model and on text i cannot find the invert setting like i can on gfx images.

On gfx images it does turn the laser off while moving to its starting point, where on the CUT (LINE) mode it stays on while moving to its starting point.

I have setup the printer OK and M106 S255 turns the laser on and M106 S0 (or M107) turns the laser off and i think thats the correct way it should be configured.

Is there someone who has experienced some similar problems ?
I really like Lightburn and if i can solve these issues i sure gonna buy the licensed verion.

Thanks in advanced

I seemed to have solve the invert burning problem by editing the GCode file that Lightburn generates and turning every M106 S0 into M106 S255 and viseVersa.
Now it burns the correct image, nothing inverted.

But strange it is…


That sounds like you have a configuration issue with the machine, like the output pin for the fan is inverted for what the laser requires for input.

I can indeed invert the pin for the fan in the firmware. I have not done that now, but i have tested it earlier with Lightburn to see what happened when i inverted the pin.
So when i inverted the pin the normal gcode M106 S0 turns the laser ON and S255 turns it off, so that is reversed from normal operation.
I expect the S255 to turn things on and not off :slight_smile:
So i put the pin back to its original setting and the laser goes off at S0 and on at S255

I’m still not done figuring this out, so i’m going to test some more.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.