Laser output does not match lightburn

I imported an svg into lightburn. When i run the preview everything looks ok but when i run the file in my laser the output is not right, the lines are not drawn in the correct places.
I am including three files, the one name screen.png shows you the configuration, the one called preview.png shows you what the preview screen looks like, and finally the result is the output of the laser.
What am i doing wrong? what is the laser output not corresponding to the file?
thanks for the help

This is almost certainly a mechanical issue. Make sure that the laser head assembly is properly secured to the gantry and that there isn’t excessive play in the components. Check belt tension and all other mechanical linkages for any slop or backlash.

Once complete, retest to see if that’s addressed the issue.

Thanks for the suggestions. I have checked the head as you recommended as well as the belts and everything seems ok.
I have also done several test changing the speed and it always engraves exactly the same way.
if the issue was a loose cable i would imagine that there would be inconsistencies between each job, but there arent any, its always the same.

I have tried an even simpler project and the resuts are the same, its not drawn properly.
The one weird thing is that even tough the dfrawing bottom left corner is at position 30,10 and i put the piece of wood at 0,0, the engraving is off as you can see from the second picture included in this message.
The home button works fine, when i click on it the laser goes to the bottom left which is correct.
Any other ideas?



Based on the results I have to think that you must be missing something on the mechanical side.

How have you checked this? If you push and pull the laser head assembly, are you able to shift the laser head forward and back? If you lift the assembly, does the assembly lift the wheels off the rails? If so, you need to close that gap. You can accomplish this typically by turning the eccentric nut located on the wheel axle.

If you’re still not finding anything let’s confirm that you there isn’t anything odd in the generated g-code.

Can you go to File->Save gcode and save the file with a .txt extension, then upload the file here for review.

I did push and pull the head assembly and the laser forwards does not move is firmly attached to the gantry. When i lift the assembly, the wheelks do not go off the rails.
I am including the g code as you requested
I really appreciate the help
pi3.txt (2.1 KB)

The geometry in the gcode itself looks fine. You can check this for yourself by changing the extension to .gcode and importing the file into LightBurn itself.

However, I can see that you’re configured with the wrong device type. You are configured for GRBL-LPC when you in fact want straight “GRBL”. Push Devices button in Laser window, then click on the name of your laser, then Edit. Change to GRBL and then complete the wizard.

However, that wouldn’t cause the issues that you’re seeing. Other thing to check for is to see if the lens itself is somehow improperly secured in the laser module. See if the entire lens barrel can be moved or if the lens itself is somehow free floating internally.

If that doesn’t reveal anything then I’d suggest mounting a camera to something steady and then take a high speed video of the motion of the laser to identify where in the mechanical chain the motion is being introduced. From your sample burns it looks like something that would be moving along the Y-axis.

THanks for that. I just changed the setting to grbl. will check the lens tomorrow and will update.
thanks again

Actually, after re reading your message:

i went back and looked at the Y axis ribbon to see if i could tighten it and sure enough, i did and just did a test and it worked!
So at least on the last design i made, the real simple one its working fine now.

Thanks for all the help :slight_smile:

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.