Laser pause burn a hole

i am using grbl 1.1 and lightburn 9.19
when i pause the burning operation the laser stay’s on and burn a hole in my table

please help

Enable Laser Mode - If you are using 1.1f or higher, and have laser mode enabled ($32=1) this won’t happen.

i am running 9.20
it accepts the command but now the pause button does not work any more

I meant which version of GRBL are you running? 1.1 has many versions - 1.1e, 1.1f, 1.1g, 1.1h …

Enabling laser mode would not make the pause button stop working. Can you elaborate on what it’s doing? Does it simply not pause now, or … ?

this what i have

Stream wordt gestart
32=1 G00 G17 G40 G21 G54 G90 M4 M8 G0X6.45Y5 Layer C00 G1Y35S900F1500 G1X21.55 G1Y0.18 M9 G1S0 M5 G90 G0 X0 Y0 M2 Stream voltooid in 0:07 M5 ALARM:3 Reset while in motion. Grbl cannot guarantee position. Lost steps are likely. Re-homing is highly recommended. ok Grbl 1.1f ['’ for help]
[MSG:’$H’|’$X’ to unlock]
[MSG:Caution: Unlocked]

it is version “f”

in the first line it is $32=1
the dollar sign missed but was in the original

That looks like it drew a single small line or two, then ended and returned home, and triggered an alarm or the board reset. Have you used this machine before, or with any other software?

i use this machine for some time succesfully til i discovered the pause problem
therefore i upgraded to 9.20
very soon after i started the cutting i pressed pause butten to minimize the the list of commands
beside the problem with the pause , the machine runs fine

LightBurn sends this command to GRBL to pause:


As documented here in GRBL:

Turn on ‘Show all’ in the console and you should see that command, and the ~ command for ‘resume’ being sent.

i have always "show all "turned on but i do not see the commands you mention

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.