Laser prints on same row several times before moving to next line

My printer will start printing accurately but at some point it starts printing on the same line. I am pretty sure that it is continuing to print each line just on the same line because it will eventually move and the finished print just looks like it has a piece taken out.

I have tried different modes, speeds, power, and images. Tried 10 times. I am new to this, and it doesn’t make sense why it would stop moving every time.

Could be loose belt, or driver stepper problem

whatever axes that’s on is definitely slipping or loosing some steps.

I’d suggest as @LazerArt advised, loose belt or a pulley that the set screw has worked it way off. That ‘step’ is pretty quick, so anything loose will show.

You could scan it the other direction… that would probably be more academic.

:smiley_cat:

Thank you. What is a driver stepper problem?
I looked at the manual and the only information provided about the driver was “LaserGRBL software, click “Tools”>“install CH340 Driver”.” After looking in CH340, it isn’t compatible with Mac and the equivalent is Laser Burn. So I went in a circle.

Thank you for the resource and the information. I hope it is just the fact that something is loose.

If one of your motors is faulty and not stepping the positions correctly. is unlikely. more likely something is loose and slipping, and when the motor tries to turn the wheel that moves the belt and moves to the next line it just slips and doesn’t actually move the head

Most machines have a controller and that controller is connected to ‘stepper motor’ drivers. This is the hardware that switches the ‘fields’ in the stepper motor. There is only two ‘drivers’ on this machine.

Here is a smaller grbl board and the driver for an axes is marked. It will drive 4 axes, generally one is for a rotary…

Part of this is how many steps the device takes to rotate one complete turn. And the timing of the pulses to the motor controllers. These are all configurable, but probably not a problem if you haven’t been changing values of the $ variables.

Just a FYI, bigger machine, bigger drivers, but how they work is the same…

Good luck

:smiley_cat:

I did just need to tighten the rubber step. I thought I did that during set up. It must have come loose because I had one successful print.