Laser Starting and Stopping (overscan is already on)

As the title says, My marlin based diode laser is starting and stopping each burn even with overscan on. You can see in the video and image what my test burn looks like. I am running the laser in synchronous mode as I was getting connections errors in buffered mode.

Thanks everyone!


Isn’t that what it’s designed to do?

Overscanning generates extra moves, past the ends of each line, switching the laser off before it fully stops, or even before it begins to decelerate, allowing the entirety of the engraving to happen at the desired head speed and then decelerating while the laser is not burning.

It’s not clear what your problem is.

If you are missing your start and end points, on a machine like that, it’s more likely to be mechanical slop.

You can see in the photo and the video how there is a very dark vertical line on the left and right of each test square. That is where the machine is coming to a stop in its horizontal (y axis) travel, turning off the laser, moving a couple of millimeters, stopping and then turning the laser back on and then continuing to move. The result is there is overburn on the left and right edges of each test square.

In the video it is more easy to see the gantry starting and stopping.

I would have expected the behavior of the laser to move in one continuous motion over the entire horizontal length of the test grid while turning the laser on and off.

Even if the laser gantry needs to stop after every small horizontal scan of each box. It was my understanding that the overscan feature would turn off the laser before the gantry stopped moving so that this kind of overburn wouldn’t happen.


I would like to eliminate the dark vertical lines on the left and right of each of the test squares.

If it’s pausing at power changes, there’s likely a compile time setting you need to change because it thinks you’re using a spindle, and it’s waiting for the RPM of that to get to the requested speed. GRBL has “laser mode” that can be enabled with a firmware setting. I’m not sure if Marlin has a similar setting, but it has settings for everything else, so I’d assume it does.

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.