Laser stays on even for position moves

grbl

(Dilly) #1

I have a grbl 1.1g controller installed on a chinese Arduino nano controller with a cheap 2 pin laser diode and everything works fine using other software. Testing lightburn on my ubuntu 18.04 machine with an existing dxf file loads fine. When I start the job it turns on the laser and it stays on for the full duration. The laser is not turning off during the positional moves when the laser should be off. Stopping the job will turn off the laser. M3 and M5 commands from the console turn the laser on/off as expected.
Why is the laser not turning on/off during positional moves.


(Oz) #2

Start with the first two things here: https://github.com/LightBurnSoftware/Documentation/blob/master/CommonGrblSetups.md

Those are the most common issues for GRBL machines (laser mode, and spindle max). If you’ve set those correctly and still have the issue, let me know.


(Dilly) #3

Current settings in GRBL were
$30=0
$31=0
Now set to:
$30=1000
$31=1
This did not resolve the problem. I worked out how to save the job to a gcode file and took a look. There is only one M4 at the start and one M5 at the end to start/stop laser. This doesnt seem right. Here is the start and end portions of the file:
; LightBurn 0.9.04
; GRBL device profile, absolute coords
G00 G17 G40 G21 G54
G90
M4
; Cut @ 100 mm/sec, 20% power
M8
G0X42.35Y4.14
G1X42.64Y3.76S200F6000
G1X43.08Y3.57
G1X43.67

G1X80.59Y10.55
G1Y70.8
M9
G1S0
M5
G90
; return to user-defined finish pos
G0 X0 Y0
M2


(Dilly) #4

Found the solution.
Reading more of the link provided above, the X-Carve section suggests to use the Grbl-M3 device if using Grbl 1.0c. I am running 1.1g but tried the M3 device and it worked for me. Thanks for the pointers.


(Oz) #5

GRBL 1.1f and later have laser mode, set by $32=1, which does two things:

  1. it adjusts the power output based on the speed of the laser

  2. it only fires during G1 moves, not G0 moves

The 2nd point is why you only see a single M4/M5 pair in the file - others are redundant when using laser mode. If you’re using an older firmware, or your 1.1g is a custom variant of an earlier 1.1 firmware, laser mode might not work properly, which would explain why you had to fall back to GRBL-M3.


(system) closed #6

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.