Laser stop during print but works when I rotate job 90°

I’ve tried many avenues, including changing out my USB cable. I’ve noticed if I rotate the job 90° and/or change the size it seems to work. Any help on this would be much appreciated.

This suggests the controller thinks you’re trying to cut / engrave something larger than the platform and prevents that from happening.

Without any more details (like the error message and so forth), here are some things to check:

  • GRBL $130 and $131 match the actual size of the X and Y axes
  • If the machine has homing switches, it homes properly
  • The pattern really does fit within the workspace
  • You’re using Absolute Coordinates or understand the implications of the other modes

The LightBurn doc on configuring GRBL machines may be helpful:

I checked the console and it said M8 N1 as the last line but didn’t say an error.
I was using current position when it happened. Lightburn was continuing but laser was disconnected. Console didn’t show a disconnection. Job was only 2 to 3inches. I set the size in the machine settings but I’ll try to check the settings inbthe console here shortly to make sure it took.

The M8 N1 is a command to the laser (to turn on a fan or air assist, IIRC), which suggests there’s a problem either with that command or with the power supply glitching in response to the additional current drawn by the air assist solenoid.

If your machine doesn’t have air assist or a fan, then perhaps you haven’t chosen the proper device type, so LightBurn is mistakenly sending commands it can’t handle.

@berainlb has an encyclopedic knowledge of such things, so he’ll be better able to figure out what’s going on.

Hmm… I’d say a Wikipedia article at best with questionable sourcing.

Can you confirm that the job stops every single time without rotation? Is it perfectly consistent? If so, can you copy and paste the contents of Console or any other error message that you get here?

Also, can you do this?

  1. File->Save Gcode
  2. Save with .txt extension
  3. Upload file here
  4. Take screenshot of Edit->Device Settings and post here

As soon as I get home. I’m gonna try To see if I can get it to happen. I will post shortly.

I tried to set all the settings/scenarios to get it to do it again. I was unable to recreate it. I will try again tonight.

This tells me it’s likely not a setting or otherwise a configuration issue. Please update if you do run into it again.

I will, thank you for your help and responses.

It did it again. Here are the things you requested.

Door-knob-hanger-15-SVG.txt (288.4 KB)

It looks like my $130 and $131 are not correct. It didn’t trigger the alarm…How do you change it? I have it set in device settings.

xTool blocks you from making changes to this directly. The only provision for making changes that I’m aware of is by changing your frame size in XCS.

I don’t see an issue with the gcode. Your Device Settings seem okay.

Can you confirm you don’t use your crosshairs for framing?

Also, can you confirm the actual symptom? Is the entire machine shutting down when not rotated? Or does the laser stop firing but motion continues? Or something else?

Is there any message in Console when this occurs?

I thought changed it in XCS…I can double check. I do not use crosshairs. It acts like a usb disconnect and stops in place. I am on my 3rd usb cord all brand new. No messages appear in Console.

Looks like my power source and laser rebooted

Seems to only hapopen during fill mode. Never in line mode.

Ah… then you’re firmly in the camp of a connection issue. This can be tricky.

Common causes:

  1. static discharge from rubber wheels. This is worse on fills than lines due to all the back and forth. Bonding and grounding the machine can address this.
  2. bad cable
  3. bad USB port
  4. electrical or radio interference
  5. noisy electrical circuit. Do you have another device kicking on during the burn? An air compressor perhaps?
  6. bad or insufficient power supply
  7. USB port sleeping

Some common causes described here:
Connection Issues - LightBurn Software Documentation

Have you made any modifications to your system other than the extended bed?

I added an extraction hose that sits on top of the laser head. It uses a cpap hose. I can remove that and test. I have steel wheels on the rail system. I kept my finger on the the x and the y axis the job completed when I did that (It could be a coincidence or in my head). I am going to try the bonding and ground. I will try to lookup some examples. I made sure I moved my plug to an outlet that doesn’t have a lot going on with it. I added a command for Linux to turn off sleep mode. I will try and test everything one by one to troubleshoot. I will report back soon.
Seriously thank you again i really appreciate it!