Laser Stopped Firing After Lightburn Update

Hi -

The laser stopped firing after a Lightburn update. I’m sure it’s a setting I need to adjust but I haven’t been able to discover which setting to change. The laser still works and I verified this by using the NEJE software. Any advice on what setting to update?

$30, $31 and $32 all look right to me.

Click Edit, wheel all the way down to Device Settings and click that one.
Make sure S-Max = 1000 the same as $30

Thanks for the quick response. It is currently set at 1000. Thoughts on other settings or other pieces to check?

Can you see a cooling fan or power on LED at the laser head?

I have a laser controller board that is separate on one of my engravers and it can be accidentally shut off. Have a look for a little on-off push button micro-switch.

I would also check the voltage at the engraver head while being careful not to short out the power supply.

Thanks for the additional information. I’ve double checked this as well.

When I use the NEJE software, the laser works. When I use Lightburn, the laser still doesn’t seem to fire.

Should I try reverting to a previous version of Lightburn? If so, do you know how I would do that?

you can, but the answer is rarely found there.

Instead let’s see if the Prefs are still in there…

Click File…
then click Load Prefs Backup

If you get a list of Prefs with various dates you should be able to select one from when it was working. It should have carried the prefs over automatically.

Thank you John! That seemed to work. Do I need to do anything to save these settings?

They seem to be automatically saved whenever there is a change.

Click File,
Click Export Prefs
make up a file name

You could also email this file to yourself so if everything crashes you can load it into a new computer and quickly get going again.

Is there any way you can upload the “bad” file vs a “good” file here? I’m curious to understand what could have caused this issue. You may need to change the file extension to .txt in order to upload.

1 Like

John - Thank you again. I’ll follow those steps to save the prefs.

Berainlb - Are you suggesting upload the bad Prefs file? I’m willing to give it a try. When I export the Prefs file it has a .lbprefs extension. How would I change it to .txt extension? My apologies if that’s a basic question, I’m still a rookie when it comes to Lightburn.

You can simply add .txt to the end of the file or switch from .lbprefs to .txt. You would do this in File Explorer. Would be great if you can upload both the “bad” and the “good” file. Then I’ll run a comparison to understand what changed to make sense of the symptom you were seeing.

1 Like

Hi Perainlb -

Thanks for running the comparison.

I pulled up previously saved designs. On some of them the laser works (meaning it will cut), some of them it doesn’t, some it works ~ 50%.

Is there a way to upload a prefs to other previously saved files?

Also, please let me know if I saved these txt files properly.

Prefs from 2.42022 - Laser doesn’t fire.txt (24.7 KB)
Prefs from 4.3.2022. - Laser fires 100 percent.txt (24.6 KB)
Prefs from 5.6.2022 - Laser fires about 40 percent.txt (24.6 KB)

I don’t see anything significant in the prefs file but it does reveal something about your cut layer settings in the prefs that doesn’t cut:

“doOutput”: false

Is it possible that you have just disabled the output for your cut layer?

Great idea to email the prefs files… I had a recent Windows10 corruption and had to rebuild the computer. Lost my library files and prefs. Duh…backup to a different drive next time.

Thanks for double checking these. There is one layer that was disabled but the others were enabled.

I reinstall firmware and drivers to see if that helps.

Thanks again.

Good suggestion, thank you!