Laser Stopping in middle of a project

Hello Friends…my laser keeps stopping in projects. I know this is common thread and I have read through previous threads with no avail. I’m providing all the information I’ve seen requested. Anything to help would be appreciated.

Here is what I know:

I’m using a NEJE Master 2 20W. The freeze occurs both in Vector and Raster but does not necessarily occur in the same spot. I have noticed it happening toward the end of a project (60+%). Sometimes when I hit “pause” and “resume” it continues (usually briefly). I believe the message: MSG: Restoring Spindle is associated with it…but I’m not 100% sure on this.

Here is what I have done so far:

  1. I have disabled screen saver
  2. I have disabled both the USB power saves
  3. Confirmed Settings were aligned for NEJE Master 2 20W.
  4. Ensured the Maximum Output was at 100/1000
  5. Read other post to ensure my issue was not solved elsewhere
  6. I’m running the most recent versions of LightBurn software and NEJE hardware

Here is the message:

Here are my settings:

This tends to occur after 60% completion of a project. It is frustrating as I am printing on EXPENSIVE MATERIAL. Any assistance would be greatly appreciated.


Hello I was facing the same problem with Neje Master 2 7W.

The machine stops working and the console shows this fancy character.
Rerunning the exact g-code again and again stops at different positions, so there must be sth. non deterministic going on.

Here is my investigation …

  • disabled any power-management options (e.g. for USB) at OS level.
  • exported the gcode to file and tested also other g-code senders, where you can influence the sender (e.g. wait for ‘OK’ before sending the next commands).
  • start sniffing the communiction, so I could see that my computer doesn’t send anything unexpected.

At this point the computer sends the correct commands but the machine responds with the fancy char.

Copy+Paste the char from the console output and converted it to hex ‘EFBFBD’ (‘FFFD’ in UTF-8), saying my command could not be converted.

This makes me think that something is not properly shielded.

  • ensured that the power and the usb cable connected to the machine are not placed in parallel
  • replaced the usb cable with a thicker shielded one

Still no success … very frustating.

Here I was still thinking that my g-code command get’s messed up to it’s way to the 328p chip … So maybe the machine’s board causes the trouble?

Again … out of ideas - or at least what I was willing to modify on the hardware’s side for now.

Then two things came up my mind …

  1. What if it is not my g-code making GRBL receiving a non parseable command
  2. What about time (shorter programs run successful)

So here we are … temperature?
The laser has it’s own fan, but what if this one is not sufficient?

The laser seems to have one wire that encodes the temparature information.
Without looking into any details here (e.g. how it is connected to the board and to which chips),
I just placed 3 fans around the machine and rerun my test program.

And this time it finished successful after ~35 minutes.
So I rerun the program 3 additional times, every time successful.

Solution for me: long running program needs more cooling

Because I have not checked the wiring - here is my somehow improper explanation:

  • When the temparatur hits a certain threshold sth. signals GRBL, which is not properly understood
  • GRBL stops processing, presenting the fancy chars back to the console

Placing fans around the machine is working, but gives not a good control.

So my next setup was to mount a single radial fan next to the laser and
put some plastic sheet on the bottom to control the airflow’s direction.

- fan cools the laser’s chassis
- ascending smoke is blown away from laser’s lense
- additional weight for machine moving part

This is how the single radial fan is mounted to my machine.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.