Laser stopping, stuttering, on X axis only?

Hi There,
I have a blue and white Chinese laser that is about 2 years old. It’s been a workhorse.

Lately though I am running into this issue…

  • 275 mm/sec
  • Zero scan angle
  • Power 20%
  • Belts tightened

As I do a burn (Vector Image) the machine will start fine but after a while (random) I get a pause, stutter and shift on the X axis. It will lose its position and keep going. Obviously screwing up the burn (pic). This only happens on the X axis.

The weird thing is this… Using the same settings and same design, if I change the scan angle to 90 the results are perfect. I don’t get it. lol

I have adjusted the belts, checked for bad, cut and loose wires. I also changed power supplies.

Why would it run perfect on a 90 degree scan angle but not at 0?

Any help would save me a bunch of drinking! Thanks!

If your design is close to the absolute limits of the size of the work area, Overscan could have asked the engraver head to decelerate after the edge of the engraving as it sweeps left-to-right. If it’s too close to the edge it could crash into the mechanism on the Right side of the work area. This would push the engraver head position to the left and it could make that awful screech noise you described.

Would you be willing to shrink the design 10% and repeat the project on a waste/scrap board?

Collision could be eliminated by moving the design away from the edges.

This jump to the left could also be Lost Motion (belts slipping, motors accelerating too fast - mechanical problems)

Inside your engraver, would the electric motors find a heavier load more resistant to motion in the X-Direction or the Y-Direction?

Reducing the Maximum travel speeds and accelerations may solve this problem.

Shrinking the project will either solve it or show that it’s a speed / acceleration problem or uncover some other thing.

Thank You. Thank You.

I believe I am well within my size limits but I am going to reduce the design as you suggest by 10%, center it in the machine and file and give it a try.

I will be trying all of your suggestions today and again thank you for such a detailed, knowledgeable reply. Just great advice!

I will report back soon.

The Ruida ‘knows’ the overscan and would have advised you of an issue there. Since it’s a ‘workhorse’ I will assume the configuration is ok.

It looks like a hardware issue, either mechanical or motor/driver area. I’m dubious it’s a controller problem at this point

This is occurring on the X axes, so changing the scan angle would only exercise the Y axes for scanning and that seems to support you have an issue with the X axes… Probably motor or driver circuits.

It definitely lost steps… strange it lost a lot all at once.

Were you watching it and did it stutter or anything?

Is is reproducible at the exact place? I bet not… if so, we could be on the wrong tail…


Thank you again Jack! It is so refreshing to be on a positive support forum with users offering polite, detailed and extremely knowledgeable advice. Compared to other forums I have used over the past few years, LightBurn’s is head and shoulders above them all!

Today I did 2 things…
Changed my USB cable after getting an error on the Ruida display. I don’t remeber the exact text but something like “can not find usb”.

Also while cleaning my laser nozzle, I notice a few “rough” spots on the top of the gantry, where the nozzle bracket slides. I cleaned that up and smoothed it out too.

After doing this I ran 3, 45 minute designs at a speed of 300 with a 0 scan angel… All 3 burns worked flawlessly. The problem now is that I don’t know exactly what the problem was. The USB cable or the roughness on the gantry. LOL

I am leaning towards the rough top of the gantry. I am also wondering how it got that way.

I have a lot of files to run tomorrow so I will let you know the outcome. hopefully everything goes smoothly.

Thanks again for taking your time to help. Very appreciated!


I’d bet on the ‘rough’ gantry. It’s always good to move them around so you know how they feel. When something goes south, it’s nice to be able to say ‘that doesn’t feel right’…

You took the right steps and solved it…

Glad you’re back in business, take care

Good luck


1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.