Laser Stops firing from gcode after 1.0 update

Running into an issue with GCODE saved out of lightburn 1.0. I’m using a JTECH 7w attached to a Onefinity Woodworker CNC. Prior to the update i had no issues (well besides trying to find settings that work on grayscale).
Things i’ve tried:
going through recommended machine settings
going through recommended software options
setting recommended options in onefinity controller for PWM spindle
verified that speeds match in lightburn and onefinity
Laser fires with manual MDI commands but only at M3s21
Laser fires at full power when test switch is activated
verified that the controller settings are the recommended ones from onefinity.

Lightburn file

Support Data.txt (7.1 KB)





job running with nothing firing even on dark black

GCODE

I just had the same problem (my laser arrived today.) All my setting match yours but what I had to do was download and use the previous version of Lightburn 0.9.24. Works like a charm now

Yeah it crossed my mind, I just want that to be my last resort.
It looks to me like the S## values aren’t even populating in the gcode…have you noticed that from when yours stopped working?

That’s what it looked like to me.

Can you post some GCode you generated from V1.0 so I can see the code? It’s quite possible there’s a new setting interacting in a bad way with your system. I notice both of you are using OneFinity machines. Are you using the GRBL-M3 profile, or GRBL? Switch to GRBL if so.

We changed the default behavior of the GRBL-M3 profile to use ‘Fast Whitespace’ and G0 moves for whitespace skipping, however the OneFinity controller (and older GRBL) seems to leave the laser enabled for G0 moves, so this change is being reverted shortly.

1 Like

GCODE is linked in my second post on this topic, i’ll link it here as well…gcode missing S Values

any updates guys? dead in the water at the moment.