Laser will not Fire in Lightburn but does fire in LaserGRBL

I am new to this and need help.

I got a new Ortur Laser Master 2 Pro S2. I set it up and it would not burn anything. I contacted Ortur and they sent me out a new Laser.
I then had a problem with the motherboard so they sent out a new one of those and now it kind of works.
I opened the LaserGRBL test file from Ortur and it turns the laser on and runs the test print however, I opened the Lightburn Test file from Ortur and it moves the laser but the laser will not turn on or burn.
I watched many hours of setup and tutorials and the laser will not fire in lightburn.
Does anyone know how to fix this?
Any help will be greatly appreciated!
Take care,
Kevin (Loach)

Here’s the Setup video from LightBurn:

Jump ahead to 13:10 and watch some of the first project settings.

Can you save the LBRN file that you had in LightBurn and share it so we can see the settings?

You may be working in mm/sec instead of mm/min. It’s a default that applies to larger engravers. Click Edit in the top bar - wheel all the way down to settings - click that and have a look at this:

1 Like


Thank you for the response. I looked at my setting and it is already on mm/min.
I have included the file however, it will not work on any file I open nor anything I create.

Take care,

KC Logo Creation File.lbrn2 (27.7 KB)

This told the whole story.

3000mm/min is pretty quick - I might be able to make a mark in stuff close to full power.

15% is 15% of full power… i’d have to be in snail-mode to make a mark in anything.

Try 600mm/min and 80% to see if that’s where the challenge lies.

What are you trying to mark? - you should make test patterns in similar material to get the line quality you want.


Thank you for your help but the laser will not turn on at all. The speed is not the issue it’s the fact that the laser doesn’t turn on at all. No light, nothing. I have a ticket out there with Ortur and one of their wonderful techs Gil. He has been so helpful but the thing that is stumping us is that it only fires when using LaserGRBL and will not even turn on in Lightburn. I have tried multiple settings and speeds but the laser doesn’t even light up let alone make a mark. I have tried full power, half power and still no light at all. It is very funny to see it work in one program and not another. I loaded the actual files from Ortur, I have uninstalled lightburn and reinstalled it and reset all setting to default yet still nothing in Lightburn.

Thank you again for your help, I really do appreciate it!

Take care,

In the laser tab, make sure that you have Com 5 or Com 1 port selected and your device is also selected in the drop down menu. I can send you a picture later when I get home

I’d like to look at the Machine Settings from Ortur and compare them to what you have in LightBurn. I think you’re really close to getting this going.

Open the Console window and enter $$.
Copy and paste that report into a reply to this thread.

After that - open this window and try to snag an image. Click Edit in the top bar - then wheel down to the wrench screwdriver icon and Click Device settings.

I’d like to confirm that LightBurn and Ortur are scaling laser power commands the same way. From your previous post it sounds like they might not be.


Thank you again for all of your help however, I just received a response back from Gil Araújo at Ortur and he solved my dilemma. When I have more time I will post what he sent me to this forum and hopefully someone else can benefit from Gil’s hard work and expertise.

Take care,

1 Like

I have the Aufero Laser 2 (very similar machine) and had to change the ‘S’ value to 10000 (Ten Thousand) to get proper power to my laser.

S Value Max value should really match the value in GRBL configuration $30. If they don’t match the power level requested will not match to the power level delivered.

For example, in a setup where S Value Max is set to 10000 while $30=1000 LightBurn will generate g-code of S100 for something set to 1% power. However, when this gets to the controller, S100 is interpreted as 10% of 1000 so will attempt to drive the laser at 10% power instead of 1%. Anything above 10% power in LightBurn will effectively be 100% power so you’ve clipped the variability in that scenario as well.

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.