Laser will not fire with 6445G controller

I seem to have gotten everything working for the most part. My laser will fire if I use the pulse button on the controller but I run a test program it will not fire. The wiring diagram in the manual conflicts with the diagram on the Ruida site for the controller. I have a 6445G controller. If someone could point me to a proper diagram I would appreciate it. The other problem is on LightBurn my drawing is in the top left hand corner and the laser goes to the bottom left corner to cut image. The documentation leaves a lot to be desired.
Any help would be very appreciated…

Did you just get this?

What ‘exactly’ is the question about the wiring? It is pretty simple.

The LPWM1 (CN5) connection is the pwm control to the laser power supply (lps.)

What is the conflict that’s causing the issue?

Did you go through the Lightburn Ruida setup?

Might want to check out the documentation on the Coordinate and Job Origin.


I have TL from power supply to L-ON1 and IN to L-An1 and ground to ground. I have the origin set properly in light burn. I have been setting up and programming CNC machines for 45 years and I can’t believe this has me stumped.

This is from the manual for the 6445G

Screenshot from 2022-01-21 21-15-57

This doesn’t show the L-An1, which I think is an analog. Does that controller have an LPWM1 connection?

I believe it is connected ok with the analog going to the input of the lps. If it wasn’t working you would get nothing from the ‘pulse’ button on the console.

My machine is not up, so I can’t read the settings. I think there must be some kind of configuration issue. The controller most likely, but can’t remember.

I know in the ‘Edit → Device Settings’ there is a ‘laser enable’ I just can’t remember if that’s for a grbl or Ruida controller. I’d check just to make sure…

Good luck


Here is the wiring diagram from the Ruida site for 6445G controller.

The LPWM1 is what’s used on my laser and most others. I understand the analog can also be used but I know the LPWM1 works…

Here is mine… The brown wire you see is the WP (water protection).

Screenshot from 2022-01-21 21-52-07

L-AN1 is unconnected and LPWM1 goes to IN on the lps…

Just seems odd that it will fire from the panel and not Lightburn… :interrobang:

Did you check for some type of a laser ‘enable’ in the Device Settings…?


I looked but I didn’t see anything about laser enable. Thanks for your help. I’ll double check my connections.

IMHO… I think the controller/laser is working. I think it’s something in the configuration of one or both.


I just checked and I have TL-L-ON1, IN-LPW1, G-GRD.
Same thing laser will pulse but no power on cutting. If I switch laser to “HIGH” in machine settings it will fire when rapiding. So I think the laser is wired correctly but still won’t fire during a test file. I’m sure it’s something minor that I’m missing.

Do not understand the meaning here.

Do you know how to examine the controller settings?

We need to look elsewhere for this issue. The hardware ‘works’ so it must be some kind of configuration issue.

I’ll fire mine up this morning so I have a reference.

If you don’t know how to do this, we’ll take it slow. I don’t know how knowledgeable you are about this and don’t want to loose you…

I asked about the ‘Device Settings’ a number of messages ago and you never responded. I need you to work with me here…


If I switch Laser 1 output signal to high in vendor settings the laser will fire when positioning. If I switch it to low it stops. Sorry about the confusion.

This ‘inverts’ the pwm, I believe. So it indicates that the controller isn’t issuing any pwm control.

How are the settings ‘Edit → Machine Settings → Vendor settings → Laser’

Screenshot from 2022-01-22 09-54-13

The first 5 or 6 should be pretty close to your settings…

I can’t really find anywhere in Lightburn that you need to enable the laser for a Ruida.

Post the information on the layer, min/max power and speed… or drop the .lbrn2 file on the edit window or use the download-icon-lightburn on the toolbar.

A screen shot like this would be nice…


I can’t see your ‘Start Speed’…

In engraving and cut panels you have a ‘Start Speed’. This is where the Ruida starts to compute the power/speed change.

If your start speed is 20mm/s with the Min/Max at 5%/80% and you run 10mm/s you will never get anything above the min or 5%. My start speed was 20mm/s when I got my machine.

The other way to handle this is set min and max to equal values. You should be fine around 50% level until you are confidant on what’s going on. It should at least fire.

Also check ‘max’ on the controller to see what the max pulse will be.

My machine will not fire below about 9.5%, so low values are probably not a good idea if you are expecting it to lase. You’ll get the hang of it…


Problem solved. Thanks for all your help.

If someone came here, it would take some time to figure out what you did to fix it. I’m not even sure…

Let others with this issue find a clear answer…

Take care, have fun

Glad we could help…


The minimum laser power was the issue. When I increased it to 50% power the laser fired. This wasn’t the case with the Cohesion 3D board. Anyway it’s working now. Now on to the new Z axis servo and auto focus.

Great, thanks for the update…

Take care have fun…


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.