Laser will only fire with CNC turned off!

Hi I’ve wired up a home made 100w co2 laser with a working area of 600x1020. Everything works fine and limits good, been in vendor settings and calibration is all ok. The problem is the laser will only fire when the CNC is turned off! It will only fire from the PSU.

Help :thinking:

Do you mean the Ruida has to be powered off? The whole thing is a CNC machine…

There are only two wires besides ground that the lps needs to operate from the Ruida.

That leaves the question, how is the lps connected?

Screenshot from 2022-04-08 16-37-17

Ruida → LPS
L-On1 … L this is ‘laser enable’

P is water protect and is usually grounded along with G.


Hi Jack thanks for your response. I will fire some pictures over to you this morning so you can see

And yes the whole Ruida has to be powered off

Hi this is how it’s connected
L-on1 - L
L-AN1 - IN

Water protect to
On cn5


Don’t follow you here. It looks like you have wp (water protect) wired to the L-AN1… ?

What kind of sensor do you have for wp?

Most of us wire LPWM1 to the IN. L-AN1 is the analog output of the Ruida.

Why do you have two wires going to L-AN1? What is this wire bundle, water protect?

Why is the red wire going to L-AN1?

Does this thing actually ‘home’ properly when booted?

Do you have ‘Crash’ switches on your machine outside of the normal ‘working area’ limit switches?

That is the only case I know of to use the Lmt*+ connections.

Screenshot from 2022-04-09 08-10-54

My suspicions are that you have it miswired, at least with L-AN1. If there is not a specific reason, I’d move that to LPWM1 on the controller. The red wire that I pointed out in the ‘bundle’ is questionable.

The type of water protection sensor only needs a pair of wires. Yours has three… a pwm sensor like this isn’t compatible with the Ruida input. It’s looking for a path to ground indicating it’s ‘active’

Good luck


Hi jack re wired the how you suggested and same results, only fires with Ruida off, it homes perfect and the limit switches on Y and X + axis are just precautionary :thinking: the water protection switch I may have bought in error thinking about it, it’s more of a flow meter hence the yellow signal wire :see_no_evil:

Could it be something in settings :thinking:

It’s a pretty simple connection from the Ruida to the lps, so I’m pretty sure it’s still not wired correctly.

You have an extra set of ‘limit switches’ for out of bounds?

Does the Ruida issue any kind of error message when you try and fire it from the control panel?

It should give you a water protection error as they flow meter you have will not allow the Ruida to function properly. What bothers me is the red wire to L-AN1.

Do you have a chiller? My wp is wired via my chiller to the machine. This will have to be fixed/turned off in the controller, which is not suggested. You need to have protection against no water flow…

Disconnect the flow meter till we get you up,

as it won’t work with the Ruida anyway and I don’t want aberrant wiring until it works, after that, it’s your problem… :crazy_face:

It’s not going to fire until the P terminal is pulled low (or grounded).

That’s the other wp input that is used by some lasers, think the K40 uses this…


Hi Jack thanks for persevering with me! I will disconnect the wp and re send pics of what I’ve done. I don’t get and messages on the display though :thinking:

I have just ordered the correct water switch

My chiller is a submersible pump with a 10 mtr copper coil in 20 Ltd of water in a fridge😳

You should have some kind of water protection.

However since you are working on it you can proceed but you have to ensure the water is flowing when you pulse it…

Removal of the flow sensor will remove some of the suspicious wiring…

If I recall, you can probably tie P to G (ground) and see if it will fire from the Ruida. You can disable the WP from the control panel…

Ensure you have ‘flow’ before firing…

Good luck


With the controller off, i am assuming you are firing with the LPS test button. Just now reading the thread! i ran into something similar when i built my machine. The flow sensor switch you are looking at is the one i purchased. i cut of their connection and ran one wire to ground and the other to WP1. I immediately noticed that the laser would not fire with the controller on. I had to run a separate wire from WP1 to the P on the LPS.

Hi Brad thanks for the heads up, I’ll keep you posted as to the progress, the laser still won’t fire with the Ruida on, only on lps :thinking:

If WP1 has the proper ‘water protect’ sensor connected to it and functions. The P input to the lps should just be grounded (enabled). Some of the more ‘simple’ machines use the P input for water protection… lacking a ‘smart’ controller…

Using only the P input to the lps, the controller doesn’t know there is a problem and keeps running the code, everything is running as if it’s lasing. The lps is blocked from turning on.

If you use the WP1 input, the controller will pause all operation. You can fix the issue and continue.

Make sense?

Don’t follow how you did this. What happened to the third wire?

A flow meter will not work with the Ruida…

I advised @1231 to disconnect it’s wiring… no use without a supporting computer/micro-controller.

I have a flow meter on mine, but the chiller is wired to the WP1 input of the Ruida.


I only have 2 wires on my WP sensor. I did it this way so if for any reason the water detect was not detected on the ruida it would shut down the LPS as well. If you just connect the P to ground the LPS will not detect. If i shut down the chiller it detects on both the ruida and LPS. Redundancy LOL

I don’t care if the lps knows or not The controller is supposed to be controlling things.

It should not change anything operational wise, but it’s an extra useless wire that could just go to G making it clear what it was there for, and only the next lug on the plug…


I understand!!! Some of what i do is overkill, people at work are used to it because of my years of dealing with 20-year-old equipment at work. LOL If the stuff functions as designed, that is one thing but i found it usually doesn’t.

Now I’m totally lost :rofl: what is the best thing to do here :flushed:

Sorry Paul LOL just follow Jacks recommendation!!