Laser won't operate with Lightburn

I have a XTool D1. I’ve got Lightburn set up, driver file installed, etc. Tried to run a test project, had the laser head in the top left, framed the test run, push start. the laser head moves to the start of the cut position and nothing happens…laser doesn’t start. I’m sure there is a setting that I missed somewhere. Any help would be appreciated

Can you take a full screenshot of LightBurn as you’re prepared to burn?


Here are three screenshots

  1. Before I pushed start
  2. Shows it goes to about 29% then stops. The laser never fires. It moves to the start position, the red cross hair blinks once, then it sits there.
  3. Shows the console, shows rebooting, next line is fsquare~square squaref~

I’ve uninstalled Lightburn and reinstalled, removed my device and reinstalled (multiple times), rebooted the laptop. I’m at a loss.

Your setup looks fine. Seems to me your controller is crashing and then rebooting.

Can you confirm that you’ve updated the firmware to allow LightBurn to work?

Does your laser work using Laserbox?

Yes I have the latest version of firmware. Everything works great in Laserbox.

Can you confirm that you used the .lbdev file from xTool to setup your device?

Can you capture the full Console output which includes what happened prior to the reboot? There’s likely something that occurred prior to the controller crashing.

I can confirm Ii used the .lbdev file from xTool.
Here is a screenshot from starting the machine and framing a test run (I framed it twice).

First part of the console when I tried to run test

Last part of the console on the test run


Can you use the “Save Gcode” button in Laser window and save the gcode to a file using .txt extension and then post that file here please?

Test Run GCode.txt (47.1 KB)

Is this the gcode from the same design as what caused the error in the screenshots above? I don’t see anything unusual in the gcode. However, I didn’t see some of the codes in the screenshot.


Can you try running the saved gcode from Laser window? Do you get the same behavior?

I had closed Lightburn before i got your last message. I set up a new test run the sams as the previous w8th the same result. I just tried to run the gcode i sent with the same behavior, no laser fire

Did it result in the same controller crash?

There’s another user experiencing what looks like the same crash after applying the latest firmware. Wonder if xTool released a bad firmware or if this is causing a bunch of bad flashes.

I sent XTool support a message earlier today. I included all the screenshots i posted here yesterday. Waiting to hear from them. Thank you for all your help!

2 posts were split to a new topic: xTool D1 - same problem?

XTool wasn’t able to assist either. So far I’m not getting anywhere with Lightburn.