Laser won't test fire, Nothing Changed, settings left alone

I cant get my laser to test fire. Its a diode laser running on GRBL. It worked fine every previous job before now. Its been sitting unplugged for a few weeks. I plug everything in as normal, connect everything and i can jog but the fire button in light burn does not work. I tried to manually input an m3 into the console on LB but again nothing. I have confirmed with a multimeter the laser is getting power, it just fails to fire.

I find it super weird that it happens all of a sudden, which leads me to think perhaps a software issues mote than hardware consider its been left aside untouched.

Anyone experienced a similar problem?

Yes, but in my case, the test fire preference was toggled off after upgrading my Mac to Catalina and I ran the App Cleaner app. Apparently, I had purged the file with my previous settings.

I believe with some software issues with other apps, deleting application support files and replacing them can fix some issues.

When you say the laser is getting power, do you mean the PWM output lines are showing a signal, or just that the laser power supply is working? If the PWM output is firing but the laser isn’t, it’s not a software problem.

Try this on the console:

G1 F1000 S100

If that doesn’t fire the laser, it’s unlikely that it’s a software issue. (and that’s really all the ‘Fire’ button in LightBurn does)

The laser has power from the supply which I’ve tested and confirmed. I will test the pwm lines first thing today. I should see 1% voltage out of 5v I think as that’s spec from my laser. Just find it weird all of a sudden it doesn’t work.


I still had the allow test fire toggled in in my main settings. Updated to the latest version of lightburn still no change.

Is bluetooth on or off? I had some issues until I read somewhere there were BT conflicts w/LB.

That’s really only been an issue when trying to scan for the laser.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.