Laserburn with Marlin 2.0 inline commands

Hello, I just downloaded the trial of Lightburn and I can’t believe how good this software is!
I have a small issue I need to solve. My setup:

Ender 3 pro with Marlin 2.0, SKR MINI E3 V3 32bit, 40W diode laser.

I am using M3-M5 commands to run the laser and Marlin needs M3 I (letter i) to activate the inline power mode.
Lightburn outputs a file like M3 P1 S25, I need to change it to M3 I P1 S25 to make it run correctly.
It is a small issue, it’s just very annoying to change the file manually and not be able to run the code directly from the software (live, I can run it with Run Gcode button).
Is there any file or setting I can modify to make this happen automatically?

I am happy to share my Marlin configuration if anyone is interested in having a multipurpose 3D printer.

Thank you
Stefano

Stefano,
What is your setup for Laser support in configuration_adv.h?

Hello, I had to modify various files and reassign pins to make it work, not only configuration_adv. Are you planning on using Laser support or can you help me figure out the Lightburn output issue? Thanks

Is there a reason the ‘Inline’ setting in the device settings doesn’t work for you?

image

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.