Lasers and motors stop within 10 seconds of starting engraving. Help!

Hello, I write from Spain, where the lightburn community is smaller. The following happens to me in a homemade laser engraver, with the laserGRBL program it works well but sometimes makes mistakes while recording the empty travel lines, when it doesn’t have to. The lightburn program is more powerful and I wanted to try it, I would certainly buy it without hesitation if it wasn’t because it stops within 10 seconds of starting to record, I guess it’s not a license issue, since they say try it before buying. The fact is that the gcode generated by this program are great from the screen SD, I have mounted an MKS DLC 2.0. I hope you can help me, thank you very much in advance.

It won’t be a license issue - there are no restrictions other than the 30 day limit on the trial.

I’m not familiar with the MKS DLC, but I assume you are running GRBL firmware since you have mentioned that. Can you write which version of GRBL is on the controller? It will say Grbl 1.xx when you connect. Also type ? and press enter in the console, and paste the text that it responds with, as that will help me know if it is a standard version of Grbl or something custom.

This is what appears on the console, version of GRBL 1.1h, I have activated the laser function and the occasional parameter adapted to my recorder. I hope you can help me, since I like this program Lightburn and I will buy it without hesitation, since I have been wanting to do laser tests for some time.

Can you also show the text for what it says when you type ? and press enter? There is some very specific information I’m looking for. And I need to know if you chose “GRBL”, “GRBL-M3”, or “GRBL-LPC” as your device type.

Hello, you mean this character “?” If so, it is the following that comes out on the console.

20191030_233136
Under optimization settings, in my case, it shows GRBL-M3. Do you have it same as in the image above?

No, just put GRBL, I will activate to see what happens. If I put M3 at 10 seconds it stops but this time it leaves the laser at minimum. That is a danger …

The only way that goes well is in normal GRBL, with variable activation of M4, since my laser is TTL. I put the error that jumps on the console. And I repeat, thank you very much for the help.

I have already solved the problem, I have the MKS screen placed on the plate’s aux, so it cannot have compatibility, unplugging the laser works perfectly without stopping. I’m happy! I have seen that on my screen I have some free jumpers, some are sure to make the connection to the PC compatible and have a screen at the same time.

The pin that should be placed on this screen is the B4. I hope it helps someone with the same problem, surely if you are looking for this MKS DLC 2.0 board and problems with engraving you will see this forum. Thank you all very much for your help, I stay in the forum in case I can learn more and help someone.

That is very strange - error:2 is “bad number format”, so it appears that having the screen connected was interfering with communication.

And my apologies - I think what I was looking for was $I (info) which echoes information about the receive buffer size.

Return the problems, :disappointed_relieved:

Type $I in the console and press enter. I would like to see the buffer size used for this controller. It might be smaller than LightBurn is expecting, and overrunning the serial receiver.

It’s also possible that you have a grounding issue or electrical noise interfering with the serial communication.

This is what it says, I really don’t know the problem because without having the screen connected to the board the laser works fine. But yesterday with the B4 pin it worked a little, which I don’t know why.

Hmm - that’s the value LightBurn is set to, so that’s not the issue. Check your USB cable and make sure you don’t have any strange grounding issues, loose wires or connections, etc.