Latest Update 1.6.01 - Loosing layer palette and other issues

Everytime I open a new session of LightBurn, the layout is returning to its own default layout, not the one I’ve just set up.

The Arrange toolbar is there and not the Arrange-Long toolbar that I’d like to keep.

Also, the Art Library is again not staying docked as was manipulated in the last session.

The Layer Palate, and the information under it, disappears upon invoking the “Save” request and will not return. I can minimize and restore the application window, see the Layer Palette for a split-second onscreen, only to see it disappear again via what seems to be an automated resizing of the application window by LightBurn.

I resize, redock, turn off Arrange, turn on Arrange-Long, save, etc., but still have to do it every single time I open a session. The worst part is losing the palette; that requires me to close and reopen the application and do it all over again.

This is on the in-house PC where I do most of my designs because I have my PC connected to my big screen TV (which is set to 1920x1080 resolution) where my tired eyes can see things better.

I’ve been plagued with the Arrange and Art Library issues for some time and gave up on finding a solution, but now losing the Layer Palette is a whole new issue.

Am I the only one having this problem?

2 Likes

Seconded, for one of my Manjaro Linux boxen.

The other, more or less identical, PC maintains the layout just fine.

The only obvious difference: the failing box has a pair of 2560×1440 displays, one in portrait mode, and the non-failing box has a single 1920×1080 display.

Now at 1.6.02…

Same issue but I’ve discovered that this does NOT happen when the Art Library is NOT being docked.
In other words, if I bring the Art Library in AND dock it, then when I save, the bottom info disappears.

Maybe this will help track down what’s going on.

Can you show a screen shot of your screen the way you want it to be kept?

Yes, I’ve got a similar problem, the program resets to its default layout settings every time I open lightburn. Its very annoying.

1 Like

Can you post a screen shot from your system?

Will do, bear with me.

Hi Oz, screenshot 1 is how I like my layout, which was like that until recently. Screenshot 2 is how it looks when I open lightburn with it reset to the default layout. As you can see I’m in the middle of a job so I’ve arranged the layout in screenshot 2 to how it looks on opening lightburn now.


I suspect it’s the font scale on your desktop display causing the problem - You have the windows on the right side arranged vertically, but that Cuts/Layers window is shorter than it’s actually allowed to be, and if LightBurn detects that things don’t fit, it will try to compensate for that.

If you right-click on your desktop, go to Display Settings, and change the Scale value to 100%, I’m betting it will behave better, because everything will have enough room.

Hi Oz, Ive tried reducing the display setting to 100% but it made everything tiny. So thinking about what you’ve explained in your last post i reduced the font size in the settings tab in lightburn and that seems to have done the trick.
Cheers, Steve.

2 Likes

Font set at 120% to hopefully make the other Windows app readable.

This makes the Windows File Explorer fonts small but barely readable. I normally run at 150% but LightBurn doesn’t seem to want to work with that size. At 150%, I am losing the bottom portion when saving and the layout resorts to some default (all described above)/.

As you can see, after making changes in both Windows Display Settings and LightBurn Settings, the fonts are really small. Albeit, usable but just barely. The good news is, now the LightBurn Display Layout stays put. It’s a trade off that I can work with.

However, I do wish I could get the text larger at the bottom. And yes, I’ve tried increasing the font size in LightBurn’s Settings. Nothing but “Default” seems to work at the moment.

Have you tried the solutions offered here?

I’m a newby having the same issue on a Mac laptop.
I can slide the interface horizontally but can’t raise it vertically to reclaim the Layers palate. I’ve tried changing system font size but that doesn’t seem to help.
Stephen

Is there a reason you cut off the entire screen shot except for the part you described in the text? I believe you, so that’s the part I am least interested in seeing. :slight_smile:

My screen looks exactly like MadamWu’s above, with the bottom of the layer icons cut off. The window is being drawn too tall. If I try to resize the window vertically, it pings back into place and won’t let me do it. I cannot resize it at all horizontally; it doesn’t even give me a cursor to do it with. Also, the windows for cut/move/laser/library/etc on the right are wider than they used to be and I can’t make them any narrower, they fill up half the screen. They will resize larger - did the minimum width change?
I just upgraded to 1.6.03 and this occurred immediately after restart. Thanks!
Edit: If I make it full screen, the bottom of the window moves back into place. Still can’t resize the other windows but at least I can see the bottom by doing that.

OK, here’s a full screen shot…
Stephen

The issue is that your screen has less vertical resolution than the two windows on the right side need in order to display correctly.

There are a couple things you can do to help this:

  • Reduce the size of the toolbar buttons (in Edit > Settings, near the top)
  • Tab the windows on the right, (so they’re overlapped, like Cuts/Layers and Console) instead of having both of them visible
  • Reduce the scale factor in your system display settings

Did you create your device manually? I believe you have a “creality.lbdev” that comes in the TF-Card.
Edit your device and define it as GRBL not GRBL-LPC.

1 Like