Layer settings seem to get mixed up?

I am new to Lightburn, having converted from RD Works. Most of my recent work is engraving and then cutting 10mm clear acrylic. By engraving, I mean I am cutting an outline with a low power rather than scanning. Each item has an “engrave” layer and a “cut” layer with different power settings. The item is grouped and there are multiple items cut in each job with cut optimisation set to cut in group then layer priority The layers are ordered so that I am engraving first, then cutting, one group at a time. This all works great BUT…I have a 750 ms cut through set in advanced settings for the 10mm cut layer, which is cutting last in the layer order. If I do not do this, the beginning of the cut will not go all the way through and the part will not release from the sheet. There is no cut through delay set for the engrave layer, however, the laser often, but not always, will apply a delay anyway, on the engrave layer, so that I get a deep cut right at the beginning of each shape, ruining the engraving. In a job I just did, only 2 pieces out of 18, all planned up together, did not have this problem.

So, in summary, I am cutting multiple items with 2 layers, but some of the advanced settings for the second layer are being applied to the first layer, thus messing up the job. Any ideas- is this likely to be Lightburn or the Ruida controller?

Without the art, it’s hard to comment.

See if this helps at all…

Screenshot from 2022-10-10 17-14-55


Can you email the file to us at and include a link to this thread? That way I can take a look at the settings used and see if I can reproduce the issue.

Thanks Oz, I have just sent a file and a photo of the problem on the finished product

Thanks Jack, unfortunately, the problem is on a layer that is being engraved, (in line mode, but at low power), so a lead in will not be practical as it will be visible on the finished product

I have done some testing and I Think I have a work around, so for the benefit of anyone else with this problem, here is my test:

The Word t"est" is engraved in line mode, then cut to a square. These 2 elements are grouped, then repeated. each repeat was rotated as I thought rotation had something to do with the issue. It turns out this is not the case.
Cut optimisation is set to group, then layer so the machine should engrave text,then cut group 1, move onto group 2 and do the same thing and so on.
The cyan engrave layer has no cut through set in advanced settings and cuts first:
The magenta cut layer has cut through enabled and is ordered to cut second
The first group was perfect, but thereafter, every group was wrong, with the cut through settings being applied to the engrave layer too.
If I ungroup everything, it all cuts OK, but does all the engraving, then all the cutting. I prefer not to work like this as if there is a problem, I can loose a lot of material.
So my final solution is: Turn ON cut through in the engrave layer, but do not configure any time or power:
Now, everything cuts OK!
For the record, here is a photo of the problem- note the deep hole at the start of each engraved element where the laser has paused.

What version of Lightburn are you running? I am having similar issues with settings on a Fill layer causing different behavior on my Line layers.

I am on 1.2.01

I was too. Just upgraded to 1.2.03 and issue still exists.

I was able to workaround my issue by unselecting “cut inner shapes first” in the Optimization Settings, but I still don’t understand how it is expected behavior. It doesn’t sound like this workaround applies to you. I’ve opened a new topic with my issue.

Brian Williams

I’ve just run a simple test with RDWorks, and it appears to do exactly the same thing, so this looks as though it could be a bug in the hardware, or possibly the versions of RDWorks I based my traffic captures on, as there have been several.

The only way for me to get the laser to not pause is, as you found, to enable cut through, set the power to zero, and the pause length small. I’ll make the changes to LightBurn’s output to enforce this.


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.