LB 1.1.03 - Warped text, AI imported shapes

Text and graphic vectors are getting distorted on me. I thought I was loosing steps or my line after fill settings were too fast. I slowed down to 20mm/s, and I get the exact same cuts. I can see the distortion/warps in the file, on the controller display so I’m lead to believe it’s not my controller/speed settings…could be absolutely wrong. The text is supposed to be filled which works ok but the line after fill doesn’t track the shapes (zero kerf offset.)

I’m creating my vectors in VCarve Pro (v11.010) and exporting as AI, importing into LB then assigning speed/pwr to groups. I’ve made no changes between LB updates, I’ve trashed quite a bit of work. Any thoughts on settings I may have bumped or changes I didn’t track properly with the last upgrade?

This looks like it might be a corrupt transfer to me. How are you connected to the laser?

If on USB can you connect via Ethernet? You could test to see if it’s really a transfer problem by saving the .rd file to a USB drive and loading on the controller.

Hmm. It’s a thunder laser mini60 btw. I’m running on Ethernet. I rebooted the PC and reset the interface. Cleared Ruida’s memory. Never had connectivity issues in 4 years. It’s an unusual corruption if it’s the controller or interface. Belts are good. Fidelity is good (I ran the image about 10 times in the image shown, multiple speeds from 20-200mm/s). I’ve rebuilt the file from scratch several times. I’m going to try several older files and see if the problem follows. I may deprecate the version and see if it’s in LB. Fills work fine. I must have flipped a bit somewhere.

I think I saw that there were some Ruida regressions in the latest versions of LB but can’t recall the specific affected systems.

The reason I suspected a bad transfer was because you can literally see the oddities in the controller screen.

So that means it’s either in the design, something happening with .rd generation, in the transfer process, or in the controller after the fact.

Another test:
Save the .rd file and try loading the file within LightBurn. Does the design look like the original or like the actual burn. That will tell you if the issue was in the .rd generation.

Thanks. I’ll give that a try. I could just have a corrupted file though I’ve regenerated a few times. I’m going to investigate how the AI export looks too.

I didn’t ask before but assume the Preview looks fine?

Yes, it renders perfectly. That’s what’s maddening.

Just kind of stabbing in the dark here, but could you try exporting it from Vcarve as something simpler than an AI document? Something like a DXF, EPS, SVG? AI files have the capacity to have a lot of odd things also stored in them that only Adobe Illustrator really uses, and maybe something in there is messing stuff up?

thanks for stabbing! I had the same thought that perhaps the AI conversion was doing something off-kilter (though I’ve been following this process for years without issue.) I ran a file completely originating within LB and got the same type of results (eliminating the possibility the AI conversion/import functions could be corrupt.)

Fills that weren’t filling in text and the line-after-fill are not following the text correctly. I have never adjusted or played with speeds or acceleration settings in the controller.

I double checked belt tensions and grub screws and did a full maintenance cycle just to be certain.

I think it’s something in either the controller or LB: likely a setting or switch I inadvertently threw. I’ve uninstalled LB and reinstalled, even deprecating back to version 0.9 with no luck yet (though I didn’t find or delete any config files that would remain as remnants to the installs within windows.)

Prints behave exceptionally consistent. I can rerun the file over and over with near perfect fidelity (ruling out backlash or loose screws) and I can reload the file from my PC with (changing from fill+line to line only etc.) with no changes in the result.

Perhaps the default acceleration in the controller is too high? (i never changed it…don’t know what it should be though.) It kind of behaves like that but the areas where it deviates aren’t where I would expect them to overshoot if accel was too high. I’m not pulling hair out just yet (because I think I have some stupid setting in LB set that perhaps does something different than what I think it does…not the first time.)

Thanks for everyone’s thoughts on this…

[EDIT] I may have mixed up the photos above from different runs…the prints always match whats rendered on the controller display. The files always render perfectly in LB on screen.

Try this:

  • Isolate just the letter ‘T’ from the design shown in your first picture (delete everything else)
  • Click ‘Save RD file’ in the Laser window
  • Click ‘Send’ to send it to the laser
  • Take a picture of what you see on the laser screen
  • Drag the .RD file you saved out back into LightBurn
  • Post a screen shot of the result in the LightBurn window

If it’s something weird in the content of the file, showing just a single letter will allow for a larger image on the controller preview screen, so we’ll at least be able to see that better, and importing the RD file back into LightBurn will show if that generated file is different than the design.

Also, if you could take a screen shot of the cut setting you’re using that could help too - double click the layer in the Cuts/Layers window to open the full-page of settings, and show those.

Oz, thanks for checking in. I did a parameter reset on the controller again and got very different results. Pretty sure something in the controller was corrupted. Some of the smaller numerals are slightly warped but this is what I would expect with the line speed setting set on the higher side.

I don’t know what the default reset cured,unfortunately, but good to know it wasn’t LightBurn or to a lesser extent something the operator did.

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.