LB for Galvo Install on MAC via USB

I’m trying to activate ly laser in LB for Galvo. I have connected the 50wJPT Galvo via USB to my Imac and it can see it.
TERMINAL

I have gone through the Add a device in LB and it finds my Laser. I also installed the markcfg7 file from my Ezcad 2 dongle.

Once installed i get an error msg in LB

I also have my 80w Omtech Co2 connected to LB and it works fine, this is connected through Ethernet which I was hoping I could do to my fiber too but it doesn’t have a ethernet port.

I’m lost and hope someone has some suggestions.

Cheers

CC

Not a MAC person here, but what do you show if you pull down the port setting that shows “Auto” I’d manually select the port that your laser is hooked to and see if that changes the behavior, as the Operating System may be selecting the incorrect port. Always better to manually select the port.

image

There is really not much of a selection … Either or all appear to work, (Auto) or Port # :7, but I have no idea where this port is, there isn’t any number only files in /dev. I just use the auto all the time.

I suspect because it doesn’t appear to put it in the /dev directory on my Ubuntu machine … but, I’m just guessing.

This is mine, connected and working using the only two options in the port field.

I was given a Mac and it’s on the shelf


I’ve seen lots of grbl machines that don’t work because of the Mac 3.0 usb interface. After going through a hub and coming out as 2.0 usb, they do work…

Don’t know if this applies to the Mac with a fiber or not…

@berainlb may be up on these.

:smile_cat: