LB stopped connecting

iMac with latest Monterey was working then just stopped connecting. I verified USB device for Snapmaker 2 was available, right clicked on devices, removed and reinstalled Snapmaker 2 device, rebooted, uninstalled all LB files, reinstalled, still same result. Simply refuses to connect. The connection panel sometimes shows connection but the console say “waiting for connection”.

I can connect to the Snapmaker 2 using terminal and other software.

Any ideas? I can’t buy this if it won’t work.

1 Like

I want to make sure I understand the situation. Are you saying that the iMac had previously connected to the laser and had been working properly for some time? And now does not?

Have you had a recent OS upgrade?

How exactly are you doing this? Can you send a screenshot of LightBurn as well as you connected to with the terminal?

Are you talking about LIghtBurn here?

One thing to check is whether or not you have another application open that’s potentially holding the serial usb connection to the laser. Also, hve you tried rebooting the computer?

Yes, it was working at one time. No other device is connected to /dev/tty.usbserial313440. Using minicom terminal I can connect to that. serial device just fine and issue commands. The Snapmaker 2 software connects fine but it is so clunky I wanted to use Lightburn.
Yes, rebooted the computer.

I am a firmware engineer and do know a bit about how these things work. I would hook up my USB analyzer but it is packed away somewhere.


Marlin SM2-4.4.11
echo:Compiled: Dec 6 2021

echo: Last Updated: 2021-12-06 | Author: Snapmaker Team
echo:Compiled: Dec 6 2021
echo: Free Memory: 24543 PlannerBufferBytes: 1792
set min_planner_speed:0.05
set min_planner_speed:0.05
echo:V73 stored settings retrieved (1077 bytes; crc 1657)
echo: G21 ; (mm)

echo:Filament settings: Disabled
echo: M200 D3.00
echo: M200 D0
echo:Steps per unit:
echo: M92 X160.00 Y160.00 Z400.00 B888.89 E212.21
echo:Maximum feedrates (units/s):
echo: M203 X150.00 Y150.00 Z40.00 E25.00
echo:Maximum Acceleration (units/s2):
echo: M201 X3000.00 Y3000.00 Z100.00 E10000.00
echo:Acceleration (units/s2): P<print_accel> R<retract_accel> T<travel_accel>
echo: M204 P1000.00 R1000.00 T1000.00
echo:Advanced: B<min_segment_time_us> S<min_feedrate> T<min_travel_feedrate> J<junc_dev>
echo: M205 B20000.00 S0.00 T0.00 P0.05 L3.00 C0.05 J0.02
echo:Home offset:
echo: M206 X-19.00 Y-10.00 Z0.00
echo:Auto Bed Leveling:
echo: M420 S0 Z0.00
echo: G29 W I0 J0 Z5.06750
echo: G29 W I1 J0 Z5.33125
echo: G29 W I2 J0 Z5.34625
echo: G29 W I3 J0 Z5.88000
echo: G29 W I4 J0 Z6.17125
echo: G29 W I0 J1 Z5.17125
echo: G29 W I1 J1 Z5.42875
echo: G29 W I2 J1 Z5.65000
echo: G29 W I3 J1 Z6.06750
echo: G29 W I4 J1 Z6.37125
echo: G29 W I0 J2 Z5.71250
echo: G29 W I1 J2 Z6.41375
echo: G29 W I2 J2 Z6.59250
echo: G29 W I3 J2 Z7.09250
echo: G29 W I4 J2 Z6.94125
echo: G29 W I0 J3 Z5.13500
echo: G29 W I1 J3 Z5.64000
echo: G29 W I2 J3 Z5.94500
echo: G29 W I3 J3 Z6.30000
echo: G29 W I4 J3 Z6.09625
echo: G29 W I0 J4 Z4.69875
echo: G29 W I1 J4 Z5.17125
echo: G29 W I2 J4 Z5.27750
echo: G29 W I3 J4 Z5.71375
echo: G29 W I4 J4 Z5.81250
echo:PID settings:
echo: M301 P13.00 I0.10 D17.00
echo:Z-Probe Offset (mm):
echo: M851 Z1.00
echo:Linear Advance:
echo: M900 K0.04
Screen exists!

Message ID region:
emergent: 0 - 2
high : 3 - 17
medium : 18 - 53
low : 54 - 127

Created marlin task!
Created HMI task!
Created heartbeat task!
Created can receiver task!
Created can event task!
Scanning modules …
No module on CAN1!

New Module: 0x20C21580
Module 0x00C21580: v1.11.4
Got axis Z, endstop: 0
length: 356 mm, lead: 8 mm`

It seems you have a pretty recently compiled version of the firmware. Have you been able to successfully connect from LightBurn since this update? Just want to validate nothing broke in the update.

Are you able to issue marlin commands in minicom manually after the startup message? I’m not really familiar with marlin but maybe something like an M503?

I don’t see why you wouldn’t be able to at least see the startup message in LightBurn console. Unless somehow if LB lost permission to access the serial device.

Yes, this is the current version I had been using till it stopped.
Yes, can issue any of the Merlin Gcode
Check device permissions:

crw-rw-rw- 1 root wheel 0x9000008 Dec 28 11:03 /dev/tty.usbserial-313440

I just noticed something in the UI, devices are specified cu.usbserialXXX and in the terminal looking at /dev they are all tty.usbserialXXX.

As I recall cu stands for “call up” on modem devices. From SO:

The idea is to supplement software in sharing a line between incoming and outgoing calls. The callin device (typically /dev/tty*) is used for incoming traffic. Any process trying to open it blocks within the open() call as long as DCD is not asserted by hardware (i.e. as long as the modem doesn’t have a carrier). During this, the callout device (typically /dev/cu* – cu stands for “calling unit”) can be freely used. Opening /dev/cu* doesn’t require DCD to be asserted and succeeds immediately. Once succeeded, the blocked open() on the callin device will be suspended, and cannot even complete when DCD is raised, until the cu device is closed again.

That way, you can have a getty listening on /dev/tty*, and can still use /dev/cu* without restrictions.

Do you know if the Snapmaker 2.0 uses an FTDI usb serial chip? If so, check out this topic:
Easel is not connecting to X-Controller on macOS Sierra - X-Carve / Troubleshooting - Inventables Community Forum

Curious if this solution helped. I had a similar issue and restarted my MacBook Pro with good results, but don’t know if it’s stable.

Yes, was aware of that but I have read:

Big Sur/Monterey DriverKit (Intel and M1) currently supports the following devices without any 3rd party driver:

  • FTDI: Most devices tested so far with standard VID/PID including…

    • KX3, K4

    • K9JM CI-V Router

    • WinkeyUSB

    • Generic UART cables
      Along with the fact it was working at point, and now it is not.

Just noticed after turning on “Show All” in the console pane that LB is constantly sending out G0 over and over. Why?

From what I understood of the issue it wasn’t that you needed a 3rd party driver to support FTDI. It’s that the included driver was interfering with other drivers that were installed.

You being able to connect to other devices seems to negate that though.

Not sure what’s going on with the G0 but it may be the way that LightBurn is initiating the connection and expecting a response.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.