LB stopped working, again!

I could not get LB to work with my iMac (see closed issue, I had to make this new one). So I went and bought a PC and it is running on a Ryzen7, 16GB RAM with Windows 11. The EXDACT same thing is happening again on PC, it connected yesterday to my Snapmaker 2 using the Snapmaker device and today it tries to connect and stays at ‘Waiting for connection’ forever. I tried the generic GRBL device and same thing. Lightburn doesnl’t like me and doesn’t want me to buy a license and I would really like to use it.

Take a look at the remedies listed here. Try each of these and see if this resolves the issue.

Tried all the suggestions, no dice. But I did notice something, when I select the GRBL instead of Snapmaker it does connect but of course the SN2 does not recognize the commands being sent. Example,

echo:Unknown command: “���M�������������������M���M���M���M���M�M�����M�������M���������M�����M���M�M�M�������M�M�����”


echo:Unknown command: “$I”



echo:Unknown command: “$H”


echo:Unknown command: “$H”


I’m not familiar with Snapmaker but found this Topic that steps through the installation. I think the main item will be setting DTR on in Device Settings.

1 Like

I often have to manually select the com port in the bottom row of the Laser window (middle of row)

I’m pretty sure your Snapmaker 2 should use Snapmaker. I believe it’s a custom version of Marlin.

Snapmaker seems to also need a CH340 driver -

The link PY posted above is excellent.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.