Left water running. Is my laser fit for the bin?


I have just come across this forum and I’m hoping someone can help me. I (very stupidly) left my water running on my laser. It is a separate power supply to the laser so the machine was switched off but the water was still running through the tube.

When I realised it was still running, the motor had burnt out on the pump and left the pump warped and melted, the tubes running to the laser were black inside with gunk and the cooling ring has detached. To cut it short I’ve really done a number on it.

I have tested the water flow sensor with a multi meter and it’s still showing power it when the sensor is triggered. I have replaced the pump and cleaned out all the tubes, i have not yet re attached the cooling ring as I don’t know the best way to do it.

The test button on the power supply is giving me nothing and the laser won’t fire. I am getting a water error message when I try and fire the laser and sometimes a work protected message.

My question is, have I wrecked my laser or is there a way to fix it? I’m not sure if I need a new tube, a new power supply, a new water flow sensor or all of the above.

I am not familiar with a lot of terms used in this forum as I’m not in any laser community so if anyone could help and explain it in simple terms I’d be very grateful.

I’m hoping it’s not fit for the bin

Well, that depends. If you had no circulation and have been firing the laser you may have damaged the tube - yes. But if it was light duty, perhaps the water inside the tube already would have provided some cooling capacity.

You’ll need a new pump either way, may as well start there. If a quick pulse doesn’t fire the tube (even just for a second, as long as you have disabled the water flow disable alarm, which you can do from inside the Ruida control) - then yeah, tube may be fried too.

Thankyou for your reply. I have already replaced the pump and I’m still getting a water error. There is a steady flow of water running through the tube and I’ve never tried to fire it with the water off. Could you advise me on how to disable the water flow disable alarm? I will try and fire it again tomorrow. Does the cracked cooling tube have anything to do with it not firing?

This is a bad tact… Fix the water flow problem… doing this will eventually cause you to use it without flow … intentional or not.

Does your machine have a Ruida controller…?

Where is it showing that there is a coolant flow error?


Thankyou! Yes it’s showing on the control panel display on the laser. I’m wondering if the water flow is not strong enough to trigger the sensor in the water flow sensor?

You said the pump melted down and the lines were full of…something… Did you pull the flow sensor and check it? It may be full of trash.

Yes I disconnected the water flow sensor, flushed it out and tested it. The multi meter was showing it had power when triggered but still getting water error message. I have ordered a new water flow senor to eliminate that problem. Although I must add that I was sometimes getting a water error before this incident happened

Most of these complete the ground when active. So you would measure full supply voltage across them if they fail to operate or are not active.

Is this wired to the unknown controller or to the lps?

If the sensor was full of crud, so is your tube… did you remove and rinse it out to ensure it’s clean?

If a piece sticks to the inner lase tube, it will crack there because there is no coolant at that specific spot. Same as stuck bubbles.

Open the return side of the coolant and observe the flow…

Most of these flow valves, like mine is really a pressure switch with only a diaphragm inside to measure pressure, not flow.

I have a hall effect flow meter…

Most controllers will allow you to disable that input, but it’s not a good idea.

What controller do you have?


thankyou for this information. I have already flushed the tube and observed the flow from the water flow sensor and everything seems fine but still no luck with getting the laser to fire. Frustrating!

What kind of controller to you have in your machine.

This can help us help you, but you need to tell us the answers to our questions.

I really don’t know what state the machine is in, and very little knowledge about how it works. If you have a dsp type controller, such as a Ruida, the debugging of this is different than a grbl debug of the same type issue.


Sorry I don’t know the name of the controller but I’ll send pictures of the controller and laser.

The laser itself is less than a year old and well maintained, apart from this mistake with the water, hoping there is a way to possibly reset the system?

Nice machine, I have one very similar… This picture is when it was pretty much stock.

The machine console is very much like yours, so I’d say you have a Ruida controller…

If you open the electronics bay door you can identify which type of Ruida you have… There is no standardized layout of where the components are located, but you can see what mine looks like…

Left of the blue wiring tray is the Ruida controller, you can read the model off the case… On the right it the laser high voltage power supply (lps) which is the high voltage that causes your tube to lase, hence dc excited laser. Rith above the horizontal blue bar is the pair of motor drivers… one for each axes. You could have three if the machine has a controllable Z axes.

You can read that mine is a 6442G model… probably what you have…

If you are not getting any arcing to the case from the high voltage power supply, it would indicate there is no hv being generated by the lps.

You can manually test fire it from the lps, but ensure you have coolant flow.

Make sense?

Do you have any way to check voltages?


Thanks for taking the time to explain that to me, I really appreciate it. I’ll attach a photo of the model. I have tried to test it and pulse it and nothing is happening, could it be because the cooling ring has cracked off? I listened to someone’s advice on another forum and reset the controller and it’s sent my machine wild, reversing all the commands so up is down, left is right etc and every time I switch it on, the laser head is slamming off yeh right hand side of the machine. I feel I am adding to the problems trying to fix it :weary:

If you didn’t save the vendors setting before the reset, you may have shot yourself in the foot.

If you do a factory reset on a Ruida, it does just that, resets it all to the default settings, and all vendor information is lost, probably why your machine went crazy…

You need to find that information, either from someone with a very similar similar machine or from your vendor.


I was fearing that. Thankyou I’ll contact them :blush:

Previous machine configurations may be available from an automatically saved file, so you can get back to something that should be close to working.

Use Edit → Machine Settings and see if the Load from Backup button produces anything of interest.

ive just seen your message, thanks very much for the advice ill give it a go tomorrow