Lens Calibration image issues

(upload://771VxRgV5f6QNNq6SucZtF8UxKQ.jpeg) Calibration%20image RgV5f6QNNq6SucZtF8UxKQ.jpeg)

I am new to lightburn, trying to get my camera set up. When I engrave the image in lens calibration, it looks right on the screen, but it engraves backwards. Then in the second step the camera takes a blank image. I have done the entire process twice, with the same result. Any suggestions?


Have you cut anything else on your machine before? Horizontally flipped output is usually from setting the origin in the wrong corner (left to right).

For the second step, make sure the lighting is even and the preview image from the camera isn’t blown out - you might need to lower the lighting level, and it’s also worth checking that the camera is in focus.

I haven’t cut anything else with the laser. I tried setting the origin in the upper left corner, same result. Then I set origin in upper right corner, same result. The image is engraving in reverse.

When I say “origin” I mean the device origin (just making sure we’re talking about the same thing).

Try this - use the text tool and type your name, and cut that. If it comes out mirrored horizontally, go to the device settings and flip the origin point to the opposite corner left to right. If it’s upside down, choose the opposite vertical corner:


OK, I use text and it burned backwards. I went to device settings and changed the origin to each of the other settings and it burned in the same place and still backwards.

Here is what I see when I make the suggested changes. Are you not seeing the same? Please post screen caps to show what you see as you make these changes.

I am having issues with the screen shots. But I duplicated what you sent and the image prints in the lower right corner backwards in all 4 origins.

How old is your laser controller, and do you know what model number it is?

3 months. It is a Ruida. I got the upside down backwards issue resolved. It was in the settings downloaded to the machine. I now have a new problem is calibration. When I hit frame, the carriage goes to the top right hard and tries to keep going. I have to turn off the machine to make it stop. I tried setting the origin on the machine and same issue.

Does your machine home correctly when powered up? Are you in “rotary mode” possibly? The camera uses “Absolute Coords” mode for job positioning, so try a generic job using that. If it doesn’t work, we’d need to solve that first.