Lighburn locked me out

I just got on my laptop, and got on Lightburn, then had to shut it down and restart. When it restarted, it told me my trial period has expired. Only problem is, i have had the lifetime version for a little over a year. Can’t find my license, and don’t know how to get my project done, since i can’t get on Lightburn.

Originally it would have been emailed to you. See if you can find it there.

Else, try logging into the License Portal to retrieve the key.

Failing that, email and they’ll help you get sorted.

Found the email, re-entered it, and after 2nd time it said activated, and finished my job. Now, went to do another job, framed the work, then clicked “start”, and didn’t do anything. Tried framing again, and pressed start again, and still doesn’t do anything, then window pops up again, saying my trial has expired. Don’t know whats going on.

me pasa lo mismo, ya hay un hilo sobre este tema, en este momento parece que el problema es global, esperemos que el equipo de lightburn lo solucione pronto

I’ve had the same problem here. I went to save a project, it wouldn’t offer a destination file into which to save it, so I lost that work. I restarted everything and was prompted to enter an activation key (Subscribed and user for 18+ months so far) I did this and was unable to save a project a second time. Restart, re-enter activation key again and a few hours later it appears to be working. I sure hope so, because it has delayed a day’s work!

The issue was caused by our Licensing service, Cryptlex - it appears to now have been remedied. Sorry for the inconvenience.

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.