Light Burn doesn't see my Laser Master

Obviously a noobie, I have the LM running ok with LaserGRBL, so I’m assuming that the unit is ok. When I try to add a device, nothing shows up in the “box”. I’ve reset the LM etc. I did try to manually install the LM, and used Gerbil-STM as I really have no idea which one to use. I did appear to install and connect to the LM, but when I tell it to show me a frame, I get Starting Stream; Alarm 2; On or near line 3; MSG Reset to continue; I right click on Device and it gives me 6 ok’s, Homing, ok.

I realize that it is me, and I did search the post for an answer but didn’t find one.

Thanks for your time.

After more searching, I see that Meyer’s said use manual install and the plain GRBL and it does connect and says READY, I have a “Test1” text in the square and this time, I just hit Start. This time it says Starting Stream, Layer C00; then Alarm:2; On or near line 6; and [MSG:Reset to continue]. A green line appears and says Busy.

Thanks again for any help.

ALARM:2 means you tried to send the machine out of bounds, and my guess is that you’re using ‘Current Position’ or ‘User Origin’ mode instead of ‘Absolute Coords’ without understanding the differences between them. Read here:

If that’s not it, it could also be that the machine wasn’t properly homed and thinks you’re going to ram the side, but start with the above.

Thank you Oz for your time. Absolute Coords was picked. This time, I loaded a file and hit home and it didn’t Alarm, just said OK. I believe that HOME is correct, on the left near the X rail. When I was able to use it with LaserGRBL, that is where it started. Now LaserGRBL says that Access to COM3 denied. Another issue.

This is the correct orientation of the machine:

If LightBurn is running and connected to your laser, LaserGRBL won’t connect (and vice versa). You can only run one of them at a time.

Thanks for the info. I should have realized that only one program open at a time. I’m right that to install LM to LB, I use the Manual option and the generic GRBL?

It should auto-detect, but there’s no issue with setting it up manually - that works fine too. Just make sure you enter the workspace size correctly (150mm wide, 160mm tall) and the origin at front-left.

FYI I could never get it to autodetect. I knew that I was an idiot, but at least I have some braincells left, which work occasionally. I thought my machine did 170x170, which is where I had it set. Thinking that it was not important I changed it to 150x160. When I did, it put my “test” outside of the “box”. Then it hit me what if the “test” was to be in the bottom left of the box, rather than where I had it, top left. I obviously didn’t notice the green square at the lower left of the box. SO NOW IT WORKS!!!

Thanks again for your help & patience.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.