Light burn will not connect to laser

Labor will not connect to my laptop and shows everything looks fine but laser not connected

What operating system are you running LightBurn on? If Windows, did you select the option for the FTDI driver at the end of the LightBurn installer?

How are you physically connected to your laser? What steps are you taking in LightBurn to try to connect?

Here are some connection troubleshooting tips:

I am running is Windows 7 and I didn’t get the option to do any installation at the end if so I must’ve missed it

Try running the installer again. The FTDI driver is available on the last page.

image

I uninstalled light burn and reinstalled it and did it correctly per your instructions and the laser is still disconnected

What steps are you taking in LightBurn to try to connect- are you using ‘Find My Laser’, but it’s not appearing, or something else?

How are you physically connected to your laser? If you’re connecting by USB, take any USB hubs or extenders out of line (they can cause issues), and try a different cable if it’s still not connecting.

I’m connecting with Find My laser, it shows the fiber laser there. I have tried different cables to connect and it still hasn’t connected. It works with easy cat no problem but it will not work with Lightburn

Apologies- the advice I gave was based on the laser you have listed in your profile, which is a DSP device.

You’ll need to install a different driver to connect to your fiber laser. If EZCad is working, it means the LightBurn driver is not installed.

If you do have the LightBurn driver installed, you’ll need to have galvo support on your license in order to connect. Does your license have galvo support?

If you email your key to support@lightburnsoftware.com, we can check for you. Please reference this thread.

My version of the software does have galvo support, the Regida controller is now missing and I can’t scan to look for my laser because it just stops working. I’ve contacted light burn support and I’ve also contact the thunder laser support I have as of yet to get this problem resolved

I have look and believe I have done all the steps correctly, still laser not connected