Light burn Xtool D1 waiting for connection

I have been using my xTool D1 flawlessly for the last few days. Still learning Lightburn and I like it. But today I had to burn something from the LaserBurn software and it worked great. But when I went back to Lightbutn. I get the “waiting for connection” error in the console. “Laser” window says my laser is ready. And Found xTool D1 in my COM4. And when I trying to burn a file. It says “There was a problem sending data to the laser. The machine may be busy or paused”.
I have had no issues up to this point. And when I go back into laser burn. It will burn any file that I import. So that tells me it is not a connection issue. I think my laser machine is still try to use the laser burn software. How do I make my machine stop looking at laser burner software?
I have uninstalled laser burn and I still can’t get LightBurn to work.

When I had a similar issue, turning the XTool and off fixed it. LaserBox sets the XTool in a “listen for LaserBox instructions” mode, you have to turn it on and off between sessions.

I can’t find where to turn it on and off in LaserBox?

Close LaserBox completely, then turn the power on and off on the XTool.

I see what your saying. I closed laserbox, and turning off xTool then back on. Kinda like a reboot deal. But it still did not work. I think my machine is stuck on laserbox mode. And there are no setting to turn it off. Turning my machine on and off does not reset it.

A few things to look at:

  1. Are you absolutely certain that your laser is on COM4? Is that the same port that Laserbox uses?
  2. Have you tried rebooting your computer? Is it possible you have an instance of LightBurn running in the background?
  3. Perhaps try reloading the firmware on the D1. Don’t know if they allow you to reload the same firmware. Or if you’re currently on an older firmware try updating.
1 Like

Yes my machine is 100% on COM4. I even switched to COM3 and it ran on both of them using LaserBox.

I have rebooted and laptop has been completely turn off for reboot many times. I have completely closed out and even uninstalled LaserBox. Still will not run Lightburn. If it’s running in the background somehow. I can’t find it. Is there another way to close it out besides just hitting the X button?

Yes I have reloaded and installed new firmware. All up to date.

I have spent hours trying to figure this out before I posted. Like I said before. I can burn in LaserBox just fine. I have uninstalled Lightburn and reinstalled and that doesn’t work either.

Perhaps try a full wipe of LB prefs folder.

  1. Open LB Prefs folder (File->Open Prefs Folder)
  2. Close LightBurn
  3. Delete all contents of Prefs folder
  4. Restart LightBurn
  5. Reconfigure your laser

This will remove all remnants of LB configuration so if you need to preserve anything do so beforehand or move the contents to another location.

So I deleted the Preps folder plus I uninstalled both programs LightBurn And Laserbox and then reinstalled. And my machine started working again. UNTIL the next day. Came out to the shop to burn and its back to being “Busy or Paused”. So I repeated the uninstall and deleting again. And this software will not talk to my D1 again.
I like this software but why am I having problems with it? Has this ever happened to anyone else?

There are many people that experience connection issues. In the end the issues are almost always something system related, hardware related, or lack of familiarity with how the laser and LightBurn behave. The D1 has its own quirks that people on this forum have struggled with.

Have you tried using a different USB cable? Are you currently using a hub or are you directly connected?

Are you still able to connect with LaserBox? I suspect the line of reasoning earlier about the machine being stuck in LaserBox mode rather than GRBL mode may be the right path to pursue. Can you enable the “Show All” button in Console… then do a power cycle of laser? Then capture all results?

I am physically connected with the USB cable that came with the D1. No hub at all.

I can still burn with LaserBox and in Light burn recognizes the D1 in the “Laser” window. It says “Ready”. Im not sure why or how to stay off LaserBox? I never opened LaserBox once i started burning with LightBurn.

I have the “Show All” button enabled of the Console. It just has a bunch of the word “Go” on it. Im assuming that is how many times I have tried to connect. Not sure how to do a
Power cycle of laser"? Or even if I can?

I think it is the path of pursue. But Im not sure how to clear that path?

Everything was working fine yesterday I burnt many small jobs. there were no issues and i never used Laserbox. Does LaserBox have to be installed on my LapTop to run LightBurn? because if not, I will uninstall it once im up and running with Lightburn.

I’m not certain about this but the answer is most likely no.

Literally unplug the machine from power or turn off if there is a switch. Make sure it’s fully powered off. If there is a switch, try physically disconnecting power, hit the switch so that all power is fully dissipated, then replug and start the machine.

Also, can you take a screenshot of your Device Settings window?

I unplugged everything from the wall. And still no luck. And changed USB cables. No luck.

I’m noticing that it seems you didn’t use the xTool D1 profile provided by xTool. I don’t think there’s any real special sauce in it but one thing I’m noticing is that the Baud Rate is different.

Can you try switching to 230,400 baud? Disable Auto-home on startup. And from what I understood D1 ignored Fast Whitespace Scan but I could be wrong about that.

You may also want to consider using the “official” D1 profile. You can find the file here:
User Manual for xTool D1 LightBurn Software – xtool

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.