Lightbrun not connecting to laser, EZ cad is

  • What machine do you have? Monport 20W

  • What controller does it have , and what firmware it is running?

  • Are you running the latest version of LightBurn?
    Running 16, the newest update changed nothing as far as connecting

  • Is the issue new, or has it happened before? What kind of computer is it, and what Operating System is it running?

Hp 360 Pavillion, windows 11

I used it about a month ago, everything installed and worked fine. Now EZcad will recognize the laser, Lightburn will not recognize the laser. I manually added it, tried auto connect, changed cords, shut everything down.

Hi Bri! welcome

Question - Can you confirm that your LightBurn Galvo Drivers are present?

Right Click windows menu > Device manager

Plug Laser and power it on.

What do you see here?

If you dont see the USBLMCV2 (or 4) it means you might need to install the LightBurn Drivers again.

The installer for the driver is in the LightBurn files at "C:\Program Files\LightBurn\EzCad2Driver" and can be run again via the “dpinst-x64.exe” file directly.

If it wont work, you can try Zadig.

If EZCad connects and Lightburn doesn’t you have the wrong driver installed. They are not compatible.


I uninstalled and re installed, and then also tried the other driver, now ex cad does nothing

until today I hadn’t changed anything, it connected and worked fine , all the right drivers, until today. There were no computer updates in this time and the only change i made was updated Lightburn today, but i reverted it back when j saw it didn’t work.

On windows, I understand that the driver for Lightburn is not compatible with EZCad.

If it ran yesterday and no drivers were changed, but doesn’t today … that makes no sense…?

Maybe it just needs to re-boot…

I got out of Windows a decade and a half ago… mainly for these types of reasons.

Good luck


As Jack said, LightBurn Replaces the Laser drivers so it can talk with the Galvo.
The moment you do this Ezcad software stops working - and lightburn works.

If Ezcad works then lightBurn drivers weren’t installed and LightBurn couldn’t work.

Wouldnt be the first time windows done crazy stuff behind the scenes though.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.