Lightburn 0.19.20 - Ubuntu - thinks left mouse button is down

I’m using Lightburn 0.9.20 on Ubuntu 18.04.5 (latest 18.04) and if you leave the app running for a while (or go into suspend/resume mode) lightburn acts like the left mouse button is being held down. Even if you exit LB and go back, the first time you click the left mouse it then thinks it’s held down for the rest of the time (it appears normal until you click left the first time).

happens with both external mouse, and trackpad… and happens on 2 different machines with 18.04

the only way to get it to go away is to completely reboot the machine (logout / login does not clear it)

@Hank @DougL @adammhaile - Have any of you ever seen this?

Nope. Not me. Never seen anything unusual happen with the mouse.

I have not seen that or anything like it either. I generally leave LightBurn running on my Macbook Air running Kubuntu 18.04 suspending and resuming all the time. The mac for some reason does great at suspend/resume compared to my Lenovos.

I’ll leave LB up on my Lenovo( Kubuntu 18.04 ) and report if I see anything mousy going on.

Not me either. That’s really odd.

@darrylburke have you verified that there is no left-mouse button issues outside of LightBurn? Are your 2 machines the same hardware?

The mouse driver is what emits the mouse events(button presses, moves, etc) so it seems odd only LightBurn would act like it’s getting left mouse button events. I’m running KUbuntu 18.04.5 on 2 different machines(Lenovo and a MacbookAir) and nether exhibit this problem. LightBurn 0.9.20 on both. Left it running over night too and no issues showed up.

Could it be you have a different version of Qt installed or something else which could go odd on mouse events?

Currently its just on LB that exhibits the problem however i have had similar issue with an older ubuntu and some java based programs. The two machines are different hardware. The most times it happens is in a dell xps 13 which has a touch screen ( tried to reproduce but unable to. Ita random over time / suspend resumes…)

I see in some old threads ( found by google ) that some others have seen this too.

Some others have seen this too in general on Ubuntu or in LightBurn?

ha, yes I saw some mentioning it as far back as 2010. Did you try disabling your touchpad as that is what solved the problem for the first 2010 thread I’m reading?

And another user found the touchpad being the cause:

Another with a similar, but not exact problem, found he can force whatever app has grabbed the mouse telling the XF86Server to ungrab(Ubuntu mouse is moving but not clicking - Unix & Linux Stack Exchange):
The command that works for me was: xdotool key XF86Ungrab

It was LB on ubuntu as well.

Im going to try those commands the next time happens and see what i get… ive disabled the soft touch ( as mine has hard buttons and known to cause some issues in general)

1 Like

another thing to try if/when it happens again(found in a forum):

The best solution I found is switching to another virtual console (TTY) by Alt + Ctrl + F1.
The mouse works normally after switching back with Alt + Ctrl + F7.

So reviving this thread as it just happened again (and is still happening now)…

I tried the switching consoles… no luck
Tried ungrabbing the mouse with xdotool. no luck.
Tried listing mouse button states with xinput (all touchpad, external mouse, and touch screen) and all list mouse buttons as “up” (but when alt-tab to lightburn it reacts as mouse button down)

right now the only running App which I see “misbehaving” is lightburn…

BINGO!!! I found it… not sure what causes it, but if I activate the touch screen (by touching it when LB is the active app) , then I go back to mouse, it goes back to “normal”

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.