Lightburn 0.9.20 imports all Illustrator .ai pages instead of selected one

Hello,

I purchased the license and was correctly importing my .ai files into Lightburn by selecting the specific page. However, after an update it imports all pages instead of the seleced one, no matter which page I select to import.

This is ultra super annoying because I then spend time deleting what I don’t want plus I can delete something I actually need. This is a very annoying issue.

My config below:

  • Lightburn 0.9.20
  • Illustrator CC 2020
  • Windows 10
  • Ruida Controller

Thank you.
Best,
J.

What you were importing before was the PDF preview content of the file, not the Illustrator content, because prior to 0.9.20 we didn’t support the new compression format in the AI file.

If you export as PDF instead of AI, you’ll get the page selection back again. If you can send a multi-page AI file to support@lightburnsoftware.com as an example, I can look to see how hard it would be to support choosing the page.

Thank you @LightBurn for the quick reply. Exporting to PDF from Illustrator to import to Lightburn adds a step in the flow. Plus, prior 0.9.20 I could edit my .ai file, save (crtl+s) and import it back into Lightburn. Now I will have to export it in PDF. I actually have tons of Lightburn files, this is why the previous flow is much more convenient.

I sent the file to support@lightburnsoftware.com: it consists in two pages with a square (resp. circle) in the first page (resp. second page). No matter which page I choose, it imports both.

If you want to make it easier.

In Illustrator, copy to clipboard the data you want in Lightburn. Then switch to Lightburn, and paste.

Thank you @RalphU for your help. I tried your solution and works. However, all the data copied in Illustrator and pasted in Lightburn is downsized. That’s a lesser issue than the initial one.

I have Illustrator CS3, and it comes in at the right scale. Do you have to scale things in Lightburn by 125%

Go to your settings, in the File Settings area, and change the SVG import DPI to 72 (Illustrator). Illustrator puts content on the clipboard in SVG format, and their SVG exports are non-standard.

I tried as you mentioned (switch to SVG 72 dpi (Illustrator)) but still the same issue: Lightburn imports all pages no matter which one I tell it to import.

That’s to fix the copy / paste scale, not the multi-page issue.

My current fix is to simply do as @RalphU mentioned: copy / paste the data I want in Lightburn. It works like a charm.

Thanks a lot for your help!

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.