Lightburn 8MP 4K-N issue

Hey team… First post, but I’ve been running Lightburn for a few months now (currently: V.1.1.03), and just received my new Lightburn camera today (8MP 4K-N). The camera functions awesomely as a raw ‘camera’ (or webcam), under the native Windows camera app, but despite aligning and calibrating in LB, I cannot seem to have it ‘live’/active, and/or update the overlay. I’ve restarted LB multiple times, I’ve rebooted the PC multiple times… still the same issues persist!

Any ideas what this noob to the forum is doing wrong?!? (I did try to search first, but either I’m the first, or (and: more likely!) I’m using the wrong search terms!)

TTP ‘Sunray’ 100W CO2 Laser, Ruida 6445S controller
Intel PC w/ i3 CPU, 16GB RAM & 256GB SSD //Windows 10 64-bit (sleep mode disabled) - dedicated machine -solely- used to operate the Laser


You’re saying the camera worked to give you a live feed to do calibration and alignment, but it doesn’t show under the Camera Control window or allow Update Overlay?

Can you confirm you’ve chosen the camera in the Camera pull-down in the Camera Control window?

A full screenshot of LightBurn with the Camera Control window open would be useful.

Also, confirm Windows security access settings for camera → LightBurn.

1 Like

Actually it didn’t - it worked well for the alignment calibration, but for the prior stage of Lens calibration, it continuously errored - failing to recognise the printed grid - even if I held the sheet of paper (supported by a 1/8" sheet of acrylic) directly in front of the camera, so I had no option but to use the ‘default’ settings for my camera… Alignment allowed me to capture the screen image of the 4x targets, and move around to locate the ctrs, but on closing that screenset, the camera doesn’t seem to respond much at all, and certainly not ‘live feeding’, or updating the overlay

I have the lightburn camera selected in the Control Window, and the Control Window ‘active’

Ah… so you’re saying it’s just that the image itself isn’t a live feed?

I recall some Topics where people were saying that the image would only update if they passed their hand underneath… can’t recall what the fix was for that.

Are you able to coax an occasional update to the feed?

Not even! Right now, opening a new instance (with the Camera Control window active, and the Lightburn camera pre-selected), it won’t capture a screenshot -at all-! The camera window is now completely blank! (But I DO appreciate your help thus far - thanks!)

Try one thing. It’s not ideal but try switching the Camera Capture System in Edit->Settings to “Default Capture System”. See if that changes things. You may need to recalibrate+align.

1 Like

Not a thing changed! HOWEVER… when I reverted to the “custom” settings, I now get a VERY jittery/delayed capture of my hand sweeping in front of the camera… I still can’t update the overlay, but I’ll take that as the tiniest modicum of progress?!? (I think?!? :rofl:)

I think any change at this point is a win. So I take it this means that you get a slow refreshed view in Camera. What happens when you try updating the overlay?

Not a darned thing. I still stare at the standard grid backdrop. So far: this has proven to be little more than an infuriatingly expensive investment in the SW vendor’s own HW (I’m in Canada, so factor-in FX, shipping AND import brokerage fees to the equation). I’m sure I may well have missed a step, ~somewhere~, but I’ve watched multiple videos (LB’s AND 3rd party), and I’ll be darned if I can see how/where…! (The raw SW works flawlessly, and has been a breath of fresh air over my own laser vendor’s preferred RDWorks (which I found astoundingly UNintuitive!), but this is starting to give me an irritated tic!! I’ll come back with fresh eyes in the am :joy:)

GOT IT! Disable -Auto Exposure- Don’t even ask me why/how… disabling that single element ‘unlocks’ the camera… I now have a darned-near-real-time ‘live’ image feed, and can update the overlay… Go figure! @berainlb , I’m indebted to you for stubborness in helping, aiding and abetting my own inherent stubbornness - Thank-you!

Nice! Where did you disable Auto Exposure?

Curious why that would cause the issue…

Within the camera controls tab - I only did so because I turned the lights off within the Laser cabinet… the image was very dark… disabling that option -immediately- gave a MUCH brighter image, allowed the Camera Control screen to show a near-real-time image, and the Update Overlay option to engage immediately! (I tested the theory by re-enabling the Auto Exposure, and sure enough - the camera reverted back into it’s ‘Locked-down’ state… Weird!! (But I’ll accept the outcome, and knowing how to resolve this issue in the future! :rofl: :wink: :+1: :beers:)

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.