Lightburn 9.11 update

I have tried more than a dozen times to download the newest version of lightburn but as soon as I click save to download it. it just stops downloading. Has anyone else had this problem? If so, what was your fix?

It just downloaded fine for me.

I just wish I knew why it won’t download for me. And it is the same on 2 different computers.

No problem here either.

1 Like

Did you try more than one browser? Do you have security software that might be blocking the download?

1 Like

Yes, I tried 2 different browsers on 2 different computers. I’ve never had this problem downloading updates before.

0.9.10 & 11 are the first updates we’re hosting on a different service (GitHub instead of Google Drive). I’m surprised you’re having issues - GitHub should be more accessible, not less.

Check the settings shown in this video, and try Chrome or another browser, if you’re using Edge or Internet Explorer:

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.