Lightburn and XCS with same settings burn differently

Issue with Lightburn and D1 Pro. Lightburn does not cut what XCS will. I make a simple 20 by 20 rectangle in both lightburn and in XCS. 1 Pass on each. 4 mm/s 100 pwr. The XCS burn cuts it clean through and it falls through. The Lightburn burn can’t even be punched out. Not sure how deep it goes but it’s still solid. This is 5mm material. Same machine, no changes. I have run this on Lightburn 0.92.XX (can’t find version number in software), 1.2.02 and 1.2.03. All do the same thing.

Why would XCS cause or allow the laser to burn higher or Lightburn be choking it?

It’s probably not been set up properly… check these…

The $30 value needs to be equal to Lightburn, which is set for 1000 via the “S-value max” in the ‘device manager’ … Whatever it is, they must be equal and $31 needs a zero value.

This controls the pwm generated and you probably restricted lightburn with mismatched values…

$32 needs to be set 1 for most grbl… its lets grbl know it’s a laser and not a ‘spindle’ type of head.

This is my best guess from what you’ve stated.

Are you running in mm/S?

Good luck


$30=1000 in both lightburn and grbl. $31 is .1. I tried to change these just to see what would happen but it does not take. I will have to go back and check $32. Just to be clear everything works. I can grayscale engrave a picture with no problems Everything looks good. I just keep noticing I was having to use higher power setting in lightburn. I then decided to try a cut test and in lightburn set to 100% I can cut thru. But in XCS it will cut thru at 50% power. I’m have the Gcode from lightburn and it looks ok to me. Haven’t figured out how to get it from XCS yet. But the S values for 100% and 90% are 1000 and 900. Maybe one software uses TTL and the other PWM or some other combination of Analog, TTL, PWM and there is a firmware bug.

The laser can’t have more power with one software package over another.

Something isn’t configured properly…

You machine may be one of those that won’t let you change it. Some let you change it, but it sets it back to a default on a reboot/reset. I can’t keep track of which do and which don’t, sorry about that…

PWM is frequency independent. Many call it the pwm base frequency or something similar, but it’s properly called the ‘period’ A 1mS period equates to a 1kHz frequency. period = 1 / frequency.

When you ask for 20% power, the control board generates a 20% pwm square wave, it is ‘high’ for 20% of the period. During that ‘on’ time you lase 100% power for 20% of the period. For 50% you lase 100% power for half the period.

Lightburn has no idea if you have a 5mW or 5kW laser. For power to be wrong with a single package would have to be the generated pwm and that would be your configuration…

If you have a voltmeter you can measure the pwm pins and see a relative power level.

All of these are pwm, some are labeled ‘ttl’ because the voltage levels are ‘ttl’ compatible. Some, like my Neje will take 12V on the control pins but they still emulate power levels the same way, with a pwm percentage.

Do you have a voltmeter? We can check out the pwm output…

Others have these machine and have no difficulties… Of course you probably should have posted it in here.

If you can’t move it maybe one of the Lightburn people can move it over there for you…


Yes. My opt-laser connected to my x-cave using 0-10v i think. This is mainly because the output is suppose to be for a VFD spindle. This is definitely a software issue but I don’t believe it’s a configuration issue. Something about the g-code. But for the moment I still can’t figure out how to get the g-code that XCS produces. The SD card is empty no matter what I do.

I don’t know of any led lasers that work on a variable voltage for power emulation. You might have to hang around until somebody that deals with them knows how to handle this…

Good luck


I did not know I had any issues either, everything works. I just noticed I had to cut slower and use more passes if using lightburn vs xcs. Do know how many others switch back and forth between packages.

Ok I found this. The issue is lightburn issuing a M8 which it says is air assist on. This was set by default. I do not believe the D1 controller has any control over air assist so I don’t know what this code does to the D1 but it alters the laser power somehow. Told lightburn to use M7 instead of M8 and it cuts the same as XCS. I just did this to see what happens. It should not issue M7 nor M8 since there is not support for air assist on d1 controller. You can also turn air assist off in the layer so neither is issued. Sometimes when loading existing lightburn files this is on by default or when using layers you have not used before. It would be nice if there was a way to turn air assist off completely and override the layer setting.

You’re at a level I can’t help you much… The problems with the m7 and m8 issues I haven’t dealt with… Maybe @berainlb will drop in and help out here…

Good luck


Thank you :pushpin:

I don’t believe there’s a way of expunging air assist from Lightburn entirely. What might work is to perhaps setup the Cut layer without air assist and then set that to Default. You could default to all to do this for all cut layers.

This way you would only see an issue if you opened an old file or opened a file from someone else.

By the way, the issue with reduced power using M8 is almost certainly a firmware bug. You may want to ask xTool about it.

Agreed. I have opened a support ticket with xtool.


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.